Skip to content

← Public intelligence

Packagist package

akeneo/pim-community-dev

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 8.8PackagistPublished

    Akeneo PIM Community Edition vulnerable to remote php code execution

    CVE-2022-46157 · GHSA-w9wc-4xcq-8gr6

    Affected
    • Packagist akeneo/pim-community-dev >= 6.0.0, < 6.0.53; < 5.0.119
    Fixed in
    5.0.1196.0.53· Vendor fix available
    Issue
    Impact Akeneo PIM Community Edition versions before v5.0.119 and v6.0.53 allows remote authenticated users to execute arbitrary PHP code on the server by uploading a crafted image. Patches Akeneo PIM Community Edition after the versions aforementioned provides patched Apache HTTP server configuration file, for docker setup and in documentation sample, to fix this vulnerability. Community Edition users must change their Apache HTTP server configuration accordingly to be protected. The patch for Cloud Based Akeneo PIM Services customers has been applied since 30th October 2022. Workarounds Replace any reference to <FilesMatch \.php$ in your apache httpd configurations with: <Location "/index.php", as shown in https://github.com/akeneo/pim-community-dev/blob/b4d79bb073c8b68ea26ab227c97cc78d86c4cba1/docker/httpd.conf#L39. <!-- References Are there any links users can visit to find out more? For more information If you have any questions or comments about this advisory: Open an issue in…

    Recommended action: Upgrade to 6.0.53 or 5.0.119 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Critical, CVSS 9.8PackagistPublished

    Akeneo PIM vulnerable to shell injection in the mass edition

    CVE-2017-1000009 · GHSA-q8cr-xphm-7gfv

    Affected
    • Packagist akeneo/pim-community-dev >= 1.4, < 1.4.28; >= 1.5, < 1.5.15; >= 1.6, < 1.6.6
    Fixed in
    1.4.281.6.61.5.15· Vendor fix available
    Issue
    Akeneo PIM CE and EE <1.6.6, <1.5.15, <1.4.28 are vulnerable to shell injection in the mass edition, resulting in remote execution.

    Recommended action: Upgrade to 1.6.6, 1.5.15 or 1.4.28 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →