Akeneo PIM Community Edition vulnerable to remote php code execution
CVE-2022-46157GHSA-w9wc-4xcq-8gr6
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (akeneo/pim-community-dev 6.0.53, 5.0.119), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist akeneo/pim-community-dev
- Affected
- >= 6.0.0, < 6.0.53< 5.0.119
- Fixed in
- 5.0.119, 6.0.53
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-w9wc-4xcq-8gr6 lists affected ranges: Packagist akeneo/pim-community-dev >=6.0.0 =0 <5.0.119
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2022-46157: 1.50% estimated exploitation activity in the next 30 days; percentile 74.32 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Akeneo PIM Community Edition versions before v5.0.119 and v6.0.53 allows remote authenticated users to execute arbitrary PHP code on the server by uploading a crafted image. Patches Akeneo PIM Community Edition after the versions aforementioned provides patched Apache HTTP server configuration file, for docker setup and in documentation sample, to fix this vulnerability. Community Edition users must change their Apache HTTP server configuration accordingly to be protected. The patch for Cloud Based Akeneo PIM Services customers has been applied since 30th October 2022. Workarounds Replace any reference to <FilesMatch \.php$ in your apache httpd configurations with: <Location "/index.php", as shown in https://github.com/akeneo/pim-community-dev/blob/b4d79bb073c8b68ea26ab227c97cc78d86c4cba1/docker/httpd.conf#L39. <!-- References Are there any links users can visit to find out more? For more information If you have any questions or comments about this advisory: Open an issue in…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-w9wc-4xcq-8gr6
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-46157 Advisory: Akeneo PIM Community Edition vulnerable to remote php code execution IDs: CVE-2022-46157, GHSA-w9wc-4xcq-8gr6 Record: https://patchnext.com/advisories/cve-2022-46157 (revision 1, source checked 26 Oct 2026, 14:00 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: akeneo/pim-community-dev 6.0.53, 5.0.119. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist akeneo/pim-community-dev: affected >= 6.0.0, < 6.0.53; < 5.0.119; fixed in 5.0.119, 6.0.53 ## Suggested inspection (read-only) - Packagist akeneo/pim-community-dev: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on akeneo/pim-community-dev. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-w9wc-4xcq-8gr6 (GitHub-reviewed advisory GHSA-w9wc-4xcq-8gr6 lists affected ranges: Packagist akeneo/pim-community-dev >=6.0.0 =0 <5.0.119) Commands are suggestions: review each one before running it.
Loading voting…