Skip to content

← Public intelligence

NuGet package

tgstation.server.api

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.3NuGetPublished

    tgstation-server's DreamMaker environment files outside the deployment directory can be compiled and ran by insufficiently permissioned users

    CVE-2024-41799 · GHSA-c3h4-9gc2-f7h4

    Affected
    • NuGet tgstation.server.api >= 4.0.0, < 6.8.0
    Fixed in
    6.8.0· Vendor fix available
    Issue
    Impact What kind of vulnerability is it? Who is impacted? Low permission users using the "Set .dme Path" privilege could potentially set malicious .dme files existing on the host machine to be compiled and executed. These .dme files could be uploaded via tgstation-server (requiring a separate, isolated privilege) or some other means. A server configured to execute in BYOND's trusted security level (requiring a third separate, isolated privilege OR being set by another user) could lead to this escalating into remote code execution via BYOND's shell() proc. The ability to execute this kind of attack is a known side effect of having privileged TGS users, but normally requires multiple privileges with known weaknesses. This vector is not intentional as it does not require control over the where deployment code is sourced from and may not require remote write access to an instance's Configuration directory. Patches Has the problem been patched? What versions should users upgrade to? This…

    Recommended action: Upgrade to 6.8.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →