tgstation-server's DreamMaker environment files outside the deployment directory can be compiled and ran by insufficiently permissioned users
CVE-2024-41799GHSA-c3h4-9gc2-f7h4
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (tgstation.server.api 6.8.0; tgstation.server.host 6.8.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
NuGet tgstation.server.api
- Affected
- >= 4.0.0, < 6.8.0
- Fixed in
- 6.8.0
NuGet tgstation.server.host
- Affected
- >= 4.0.0, < 6.8.0
- Fixed in
- 6.8.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-c3h4-9gc2-f7h4 lists affected ranges: NuGet tgstation.server.api >=4.0.0 =4.0.0 <6.8.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 7.3 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:L/VA:H/SC:H/SI:L/SA:H · score source
- EPSS
- CVE-2024-41799: 1.21% estimated exploitation activity in the next 30 days; percentile 68.47 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact What kind of vulnerability is it? Who is impacted? Low permission users using the "Set .dme Path" privilege could potentially set malicious .dme files existing on the host machine to be compiled and executed. These .dme files could be uploaded via tgstation-server (requiring a separate, isolated privilege) or some other means. A server configured to execute in BYOND's trusted security level (requiring a third separate, isolated privilege OR being set by another user) could lead to this escalating into remote code execution via BYOND's shell() proc. The ability to execute this kind of attack is a known side effect of having privileged TGS users, but normally requires multiple privileges with known weaknesses. This vector is not intentional as it does not require control over the where deployment code is sourced from and may not require remote write access to an instance's Configuration directory. Patches Has the problem been patched? What versions should users upgrade to? This…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-c3h4-9gc2-f7h4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-41799 Advisory: tgstation-server's DreamMaker environment files outside the deployment directory can be compiled and ran by insufficiently permissioned users IDs: CVE-2024-41799, GHSA-c3h4-9gc2-f7h4 Record: https://patchnext.com/advisories/cve-2024-41799 (revision 1, source checked 26 Oct 2026, 17:00 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: tgstation.server.api 6.8.0; tgstation.server.host 6.8.0. A vendor fix does not mean a deployment is fixed. ## Affected components - NuGet tgstation.server.api: affected >= 4.0.0, < 6.8.0; fixed in 6.8.0 - NuGet tgstation.server.host: affected >= 4.0.0, < 6.8.0; fixed in 6.8.0 ## Suggested inspection (read-only) - NuGet tgstation.server.api: check the installed version with your package manager. - NuGet tgstation.server.host: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on tgstation.server.api, tgstation.server.host. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-c3h4-9gc2-f7h4 (GitHub-reviewed advisory GHSA-c3h4-9gc2-f7h4 lists affected ranges: NuGet tgstation.server.api >=4.0.0 =4.0.0 <6.8.0) Commands are suggestions: review each one before running it.
Loading voting…