Skip to content

← Public intelligence

NuGet package

system.private.servicemodel

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 5.5NuGetPublished

    Improper Certificate Validation in Microsoft .NET Framework components

    CVE-2018-8356 · GHSA-p9wx-v264-q34p

    Affected
    • NuGet system.private.servicemodel >= 4.0.0, < 4.1.3; >= 4.3.0, < 4.3.3; >= 4.4.0, < 4.4.4; >= 4.5.0, < 4.5.3
    Fixed in
    4.1.34.4.44.5.34.3.3· Vendor fix available
    Issue
    A security feature bypass vulnerability exists when Microsoft .NET Framework components do not correctly validate certificates, aka ".NET Framework Security Feature Bypass Vulnerability." This affects .NET Framework 4.7.2, Microsoft .NET Framework 3.0, Microsoft .NET Framework 4.6.2/4.7/4.7.1/4.7.2, ASP.NET Core 1.1, Microsoft .NET Framework 4.5.2, ASP.NET Core 2.0, ASP.NET Core 1.0, .NET Core 1.1, Microsoft .NET Framework 3.5, Microsoft .NET Framework 3.5.1, Microsoft .NET Framework 4.6/4.6.1/4.6.2, .NET Core 1.0, .NET Core 2.0, Microsoft .NET Framework 4.6, Microsoft .NET Framework 4.6/4.6.1/4.6.2/4.7/4.7.1/4.7.1/4.7.2, Microsoft .NET Framework 4.7.2.

    Recommended action: Upgrade to 4.5.3, 4.4.4, 4.3.3 or 4.1.3 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. High, CVSS 7.5NuGetPublished

    Improper Certificate Validation in Microsoft .NET Framework components

    CVE-2018-0786 · GHSA-jc8g-xhw5-6x46

    Affected
    • NuGet system.private.servicemodel >= 4.4.0, <= 4.4.0; >= 4.3.0, <= 4.3.0; >= 4.1.0, <= 4.1.0
    Fixed in
    4.4.14.3.14.1.1· Vendor fix available
    Issue
    Microsoft .NET Framework 2.0 SP2, 3.0 SP2, 3.5, 3.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1, .NET Core 1.0 and 2.0, and PowerShell Core 6.0.0 allow a security feature bypass vulnerability due to the way certificates are validated, aka ".NET Security Feature Bypass Vulnerability."

    Recommended action: Upgrade to 4.4.1, 4.3.1 or 4.1.1 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →