Skip to content

← Actionable
Medium, CVSS 5.5

Improper Certificate Validation in Microsoft .NET Framework components

CVE-2018-8356GHSA-p9wx-v264-q34p

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (system.servicemodel.duplex 4.5.3, 4.4.4, 4.3.3, 4.0.4; system.servicemodel.primitives 4.5.3, 4.4.4, 4.3.3, 4.1.3; system.servicemodel.http 4.5.3, 4.4.4, 4.3.3, 4.1.3; system.servicemodel.security 4.5.3, 4.4.4, 4.3.3, 4.0.4; system.servicemodel.nettcp 4.5.3, 4.4.4, 4.3.3, 4.1.3; 1 more package under Affected packages), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • NuGet system.servicemodel.duplex

    Affected
    >= 4.3.0, < 4.3.3>= 4.4.0, < 4.4.4>= 4.5.0, < 4.5.3>= 4.0.0, <= 4.0.2
    Fixed in
    4.4.4, 4.5.3, 4.3.3, 4.0.4
  • NuGet system.servicemodel.primitives

    Affected
    >= 4.3.0, < 4.3.3>= 4.4.0, < 4.4.4>= 4.5.0, < 4.5.3>= 4.0.0, < 4.1.3
    Fixed in
    4.1.3, 4.4.4, 4.5.3, 4.3.3
  • NuGet system.servicemodel.http

    Affected
    >= 4.3.0, < 4.3.3>= 4.4.0, < 4.4.4>= 4.5.0, < 4.5.3>= 4.0.0, < 4.1.3
    Fixed in
    4.1.3, 4.4.4, 4.5.3, 4.3.3
  • NuGet system.servicemodel.security

    Affected
    >= 4.3.0, < 4.3.3>= 4.4.0, < 4.4.4>= 4.5.0, < 4.5.3>= 4.0.0, <= 4.0.2
    Fixed in
    4.4.4, 4.5.3, 4.3.3, 4.0.4
  • NuGet system.servicemodel.nettcp

    Affected
    >= 4.3.0, < 4.3.3>= 4.4.0, < 4.4.4>= 4.5.0, < 4.5.3>= 4.0.0, < 4.1.3
    Fixed in
    4.1.3, 4.4.4, 4.5.3, 4.3.3
  • NuGet system.private.servicemodel

    Affected
    >= 4.0.0, < 4.1.3>= 4.3.0, < 4.3.3>= 4.4.0, < 4.4.4>= 4.5.0, < 4.5.3
    Fixed in
    4.1.3, 4.4.4, 4.5.3, 4.3.3

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-p9wx-v264-q34p lists affected ranges: NuGet system.private.servicemodel >=4.0.0 =4.3.0 =4.4.0 =4.5.0 =4.3.0 =4.4.0 =4.5.0 =4.0.0 =4.3.0 =4.4.0 =4.5.0 =4.0.0 =4.3.0 =4.4.0 =4.5.0 =4.0.0 <4.1.3; NuGet system.servicemodel.primitives…

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.5 · CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
EPSS
  • CVE-2018-8356: 0.75% estimated exploitation activity in the next 30 days; percentile 54.94 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A security feature bypass vulnerability exists when Microsoft .NET Framework components do not correctly validate certificates, aka ".NET Framework Security Feature Bypass Vulnerability." This affects .NET Framework 4.7.2, Microsoft .NET Framework 3.0, Microsoft .NET Framework 4.6.2/4.7/4.7.1/4.7.2, ASP.NET Core 1.1, Microsoft .NET Framework 4.5.2, ASP.NET Core 2.0, ASP.NET Core 1.0, .NET Core 1.1, Microsoft .NET Framework 3.5, Microsoft .NET Framework 3.5.1, Microsoft .NET Framework 4.6/4.6.1/4.6.2, .NET Core 1.0, .NET Core 2.0, Microsoft .NET Framework 4.6, Microsoft .NET Framework 4.6/4.6.1/4.6.2/4.7/4.7.1/4.7.1/4.7.2, Microsoft .NET Framework 4.7.2.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-p9wx-v264-q34p

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2018-8356

Advisory: Improper Certificate Validation in Microsoft .NET Framework components
IDs: CVE-2018-8356, GHSA-p9wx-v264-q34p
Record: https://patchnext.com/advisories/cve-2018-8356 (revision 1, source checked 26 Oct 2026, 16:58 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: system.servicemodel.duplex 4.5.3, 4.4.4, 4.3.3, 4.0.4; system.servicemodel.primitives 4.5.3, 4.4.4, 4.3.3, 4.1.3; system.servicemodel.http 4.5.3, 4.4.4, 4.3.3, 4.1.3; system.servicemodel.security 4.5.3, 4.4.4, 4.3.3, 4.0.4; system.servicemodel.nettcp 4.5.3, 4.4.4, 4.3.3, 4.1.3; system.private.servicemodel 4.5.3, 4.4.4, 4.3.3, 4.1.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- NuGet system.servicemodel.duplex: affected >= 4.3.0, < 4.3.3; >= 4.4.0, < 4.4.4; >= 4.5.0, < 4.5.3; >= 4.0.0, <= 4.0.2; fixed in 4.4.4, 4.5.3, 4.3.3, 4.0.4
- NuGet system.servicemodel.primitives: affected >= 4.3.0, < 4.3.3; >= 4.4.0, < 4.4.4; >= 4.5.0, < 4.5.3; >= 4.0.0, < 4.1.3; fixed in 4.1.3, 4.4.4, 4.5.3, 4.3.3
- NuGet system.servicemodel.http: affected >= 4.3.0, < 4.3.3; >= 4.4.0, < 4.4.4; >= 4.5.0, < 4.5.3; >= 4.0.0, < 4.1.3; fixed in 4.1.3, 4.4.4, 4.5.3, 4.3.3
- NuGet system.servicemodel.security: affected >= 4.3.0, < 4.3.3; >= 4.4.0, < 4.4.4; >= 4.5.0, < 4.5.3; >= 4.0.0, <= 4.0.2; fixed in 4.4.4, 4.5.3, 4.3.3, 4.0.4
- NuGet system.servicemodel.nettcp: affected >= 4.3.0, < 4.3.3; >= 4.4.0, < 4.4.4; >= 4.5.0, < 4.5.3; >= 4.0.0, < 4.1.3; fixed in 4.1.3, 4.4.4, 4.5.3, 4.3.3
- NuGet system.private.servicemodel: affected >= 4.0.0, < 4.1.3; >= 4.3.0, < 4.3.3; >= 4.4.0, < 4.4.4; >= 4.5.0, < 4.5.3; fixed in 4.1.3, 4.4.4, 4.5.3, 4.3.3

## Suggested inspection (read-only)
- NuGet system.servicemodel.duplex: check the installed version with your package manager.
- NuGet system.servicemodel.primitives: check the installed version with your package manager.
- NuGet system.servicemodel.http: check the installed version with your package manager.
- NuGet system.servicemodel.security: check the installed version with your package manager.
- NuGet system.servicemodel.nettcp: check the installed version with your package manager.
- NuGet system.private.servicemodel: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on system.servicemodel.duplex, system.servicemodel.primitives, system.servicemodel.http, system.servicemodel.security, system.servicemodel.nettcp, system.private.servicemodel.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-p9wx-v264-q34p (GitHub-reviewed advisory GHSA-p9wx-v264-q34p lists affected ranges: NuGet system.private.servicemodel >=4.0.0 =4.3.0 =4.4.0 =4.5.0 =4.3.0 =4.4.0 =4.5.0 =4.0.0 =4.3.0 =4.4.0 =4.5.0 =4.0.0 =4.3.0 =4.4.0 =4.5.0 =4.0.0 <4.1.3; NuGet system.servicemodel.primitives…)

Commands are suggestions: review each one before running it.

Loading voting…