Skip to content

← Public intelligence

NuGet package

piranha

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 8.1NuGetPublished

    Cross-Site Request Forgery in PiranhaCMS

    CVE-2021-25976 · GHSA-ppq7-88c7-q879

    Affected
    • NuGet piranha >= 4.0.0-alpha1, <= 9.2.0
    Fixed in
    10.0-alpha1· Vendor fix available
    Issue
    In PiranhaCMS, versions 4.0.0-alpha1 to 9.2.0 are vulnerable to cross-site request forgery (CSRF) when performing various actions supported by the management system, such as deleting a user, deleting a role, editing a post, deleting a media folder etc., when an ID is known.

    Recommended action: Upgrade to 10.0-alpha1 (pre-release) or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Medium, CVSS 5.4NuGetPublished

    Cross-site Scripting in PiranhaCMS

    CVE-2021-25977 · GHSA-jvjp-vh27-r9h5

    Affected
    • NuGet piranha >= 7.0.0, < 9.2.0
    Fixed in
    9.2.0· Vendor fix available
    Issue
    In PiranhaCMS, versions 7.0.0 to 9.1.1 are vulnerable to stored XSS due to the page title improperly sanitized. By creating a page with a specially crafted page title, a low privileged user can trigger arbitrary JavaScript execution.

    Recommended action: Upgrade to 9.2.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →