Cross-Site Request Forgery in PiranhaCMS
CVE-2021-25976GHSA-ppq7-88c7-q879
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (piranha 10.0-alpha1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
NuGet piranha
- Affected
- >= 4.0.0-alpha1, <= 9.2.0
- Fixed in
- 10.0-alpha1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-ppq7-88c7-q879 lists affected ranges: NuGet piranha >=4.0.0-alpha1 <=9.2.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:H
- EPSS
- CVE-2021-25976: 0.46% estimated exploitation activity in the next 30 days; percentile 39.60 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
In PiranhaCMS, versions 4.0.0-alpha1 to 9.2.0 are vulnerable to cross-site request forgery (CSRF) when performing various actions supported by the management system, such as deleting a user, deleting a role, editing a post, deleting a media folder etc., when an ID is known.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-ppq7-88c7-q879
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-25976 Advisory: Cross-Site Request Forgery in PiranhaCMS IDs: CVE-2021-25976, GHSA-ppq7-88c7-q879 Record: https://patchnext.com/advisories/cve-2021-25976 (revision 1, source checked 26 Oct 2026, 16:59 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: piranha 10.0-alpha1. A vendor fix does not mean a deployment is fixed. ## Affected components - NuGet piranha: affected >= 4.0.0-alpha1, <= 9.2.0; fixed in 10.0-alpha1 ## Suggested inspection (read-only) - NuGet piranha: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on piranha. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-ppq7-88c7-q879 (GitHub-reviewed advisory GHSA-ppq7-88c7-q879 lists affected ranges: NuGet piranha >=4.0.0-alpha1 <=9.2.0) Commands are suggestions: review each one before running it.
Loading voting…