Skip to content

← Public intelligence

NuGet package

opcfoundation.netstandard.opc.ua

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

6 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 5.3NuGetPublished

    Security Update for the OPC UA .NET Standard Stack

    CVE-2024-45526 · GHSA-7vfh-cqpc-4267

    Affected
    • NuGet opcfoundation.netstandard.opc.ua < 1.5.374.118
    Fixed in
    1.5.374.118· Vendor fix available
    Issue
    This security update resolves a vulnerability in the OPC UA .NET Standard Stack that allows an unauthorized attacker to trigger a gradual degradation in performance.

    Recommended action: Upgrade to 1.5.374.118 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. High, CVSS 7.5NuGetPublished

    Security Update for the OPC UA .NET Standard Stack

    GHSA-qm9f-c3v9-wphv

    Affected
    • NuGet opcfoundation.netstandard.opc.ua < 1.05.374.54
    Fixed in
    1.05.374.54· Vendor fix available
    Issue
    This security update resolves a vulnerability in the OPC UA .NET Standard Stack that enables an unauthorized attacker to trigger a rapid increase in memory consumption.

    Recommended action: Upgrade to 1.05.374.54 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. High, CVSS 7.5NuGetPublished

    Insufficient Session Expiration and TOCTOU Race Condition in OPC FOundation UA .Net Standard

    CVE-2020-8867 · GHSA-9q94-v7ch-mxqw

    Affected
    • NuGet opcfoundation.netstandard.opc.ua <= 1.4.358.30
    Fixed in
    1.4.359.31· Vendor fix available
    Issue
    This vulnerability allows remote attackers to create a denial-of-service condition on affected installations of OPC Foundation UA .NET Standard 1.04.358.30. Authentication is not required to exploit this vulnerability. The specific flaw exists within the handling of sessions. The issue results from the lack of proper locking when performing operations on an object. An attacker can leverage this vulnerability to create a denial-of-service condition against the application. Was ZDI-CAN-10295.

    Recommended action: Upgrade to 1.4.359.31 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  4. Medium, CVSS 5.3NuGetPublished

    OPC UA applications can allow a remote attacker to determine a Server's private key

    CVE-2018-7559 · GHSA-gr4c-5rq6-cgh3

    Affected
    • NuGet opcfoundation.netstandard.opc.ua <= 1.3.352.11
    Fixed in
    1.3.352.12· Vendor fix available
    Issue
    An issue was discovered in OPC UA .NET Standard Stack and Sample Code before GitHub commit 2018-04-12, and OPC UA .NET Legacy Stack and Sample Code before GitHub commit 2018-03-13. A vulnerability in OPC UA applications can allow a remote attacker to determine a Server's private key by sending carefully constructed bad UserIdentityTokens as part of an oracle attack.

    Recommended action: Upgrade to 1.3.352.12 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  5. High, CVSS 7.5NuGetPublished

    High severity vulnerability that affects OPCFoundation.NetStandard.Opc.Ua

    CVE-2018-12086 · GHSA-782p-53wq-cxmj

    Affected
    • NuGet opcfoundation.netstandard.opc.ua <= 1.4.352.12
    Fixed in
    1.4.353.15· Vendor fix available
    Issue
    Buffer overflow in OPC UA applications allows remote attackers to trigger a stack overflow with carefully structured requests.

    Recommended action: Upgrade to 1.4.353.15 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  6. Medium, CVSS 5.3NuGetPublished

    Moderate severity vulnerability that affects OPCFoundation.NetStandard.Opc.Ua

    CVE-2018-12087 · GHSA-8336-mxp6-v5h9

    Affected
    • NuGet opcfoundation.netstandard.opc.ua <= 1.4.352.12
    Fixed in
    1.4.353.15· Vendor fix available
    Issue
    Failure to validate certificates in OPC Foundation UA Client Applications communicating without security allows attackers with control over a piece of network infrastructure to decrypt passwords.

    Recommended action: Upgrade to 1.4.353.15 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →