Skip to content

← Actionable
High, CVSS 7.5

Security Update for the OPC UA .NET Standard Stack

GHSA-qm9f-c3v9-wphv

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (opcfoundation.netstandard.opc.ua 1.05.374.54; opcfoundation.netstandard.opc.ua.core 1.05.374.54), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

This security update resolves a vulnerability in the OPC UA .NET Standard Stack that enables an unauthorized attacker to trigger a rapid increase in memory consumption.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-qm9f-c3v9-wphv

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-qm9f-c3v9-wphv

Advisory: Security Update for the OPC UA .NET Standard Stack
IDs: GHSA-qm9f-c3v9-wphv
Record: https://patchnext.com/advisories/ghsa-qm9f-c3v9-wphv (revision 1, source checked 26 Oct 2026, 17:00 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: opcfoundation.netstandard.opc.ua 1.05.374.54; opcfoundation.netstandard.opc.ua.core 1.05.374.54. A vendor fix does not mean a deployment is fixed.

## Affected components
- NuGet opcfoundation.netstandard.opc.ua: affected < 1.05.374.54; fixed in 1.05.374.54
- NuGet opcfoundation.netstandard.opc.ua.core: affected < 1.05.374.54; fixed in 1.05.374.54

## Suggested inspection (read-only)
- NuGet opcfoundation.netstandard.opc.ua: check the installed version with your package manager.
- NuGet opcfoundation.netstandard.opc.ua.core: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on opcfoundation.netstandard.opc.ua, opcfoundation.netstandard.opc.ua.core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-qm9f-c3v9-wphv (GitHub-reviewed advisory GHSA-qm9f-c3v9-wphv lists affected ranges: NuGet opcfoundation.netstandard.opc.ua.core >=0 =0 <1.05.374.54)

Commands are suggestions: review each one before running it.

Loading voting…