High, CVSS 7.5NuGetPublished
Denial of service in ASP.NET Core
CVE-2017-11883 · GHSA-f9jc-rrm2-pmfg
- Affected
- NuGet microsoft.net.http.server >= 1.0.0, < 1.0.6; >= 1.1.0, < 1.1.4
- Fixed in
- 1.1.41.0.6· Vendor fix available
- Issue
- .NET Core 1.0, 1.1, and 2.0 allow an unauthenticated attacker to remotely cause a denial of service attack against a .NET Core web application by improperly handling web requests, aka ".NET CORE Denial Of Service Vulnerability".
Recommended action: Upgrade to 1.1.4 or 1.0.6 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.