Denial of service in ASP.NET Core
CVE-2017-11883GHSA-f9jc-rrm2-pmfg
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (microsoft.aspnetcore.server.httpsys 2.0.2; microsoft.net.http.server 1.1.4, 1.0.6; microsoft.aspnetcore.server.weblistener 1.1.4, 1.0.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
NuGet microsoft.aspnetcore.server.httpsys
- Affected
- >= 2.0.0, < 2.0.2
- Fixed in
- 2.0.2
NuGet microsoft.net.http.server
- Affected
- >= 1.0.0, < 1.0.6>= 1.1.0, < 1.1.4
- Fixed in
- 1.1.4, 1.0.6
NuGet microsoft.aspnetcore.server.weblistener
- Affected
- >= 1.0.0, < 1.0.6>= 1.1.0, < 1.1.4
- Fixed in
- 1.1.4, 1.0.6
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-f9jc-rrm2-pmfg lists affected ranges: NuGet microsoft.aspnetcore.server.weblistener >=1.0.0 =1.1.0 =1.0.0 =1.1.0 =2.0.0 <2.0.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2017-11883: 8.53% estimated exploitation activity in the next 30 days; percentile 95.06 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
.NET Core 1.0, 1.1, and 2.0 allow an unauthenticated attacker to remotely cause a denial of service attack against a .NET Core web application by improperly handling web requests, aka ".NET CORE Denial Of Service Vulnerability".
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-f9jc-rrm2-pmfg
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2017-11883 Advisory: Denial of service in ASP.NET Core IDs: CVE-2017-11883, GHSA-f9jc-rrm2-pmfg Record: https://patchnext.com/advisories/cve-2017-11883 (revision 1, source checked 26 Oct 2026, 16:58 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: microsoft.aspnetcore.server.httpsys 2.0.2; microsoft.net.http.server 1.1.4, 1.0.6; microsoft.aspnetcore.server.weblistener 1.1.4, 1.0.6. A vendor fix does not mean a deployment is fixed. ## Affected components - NuGet microsoft.aspnetcore.server.httpsys: affected >= 2.0.0, < 2.0.2; fixed in 2.0.2 - NuGet microsoft.net.http.server: affected >= 1.0.0, < 1.0.6; >= 1.1.0, < 1.1.4; fixed in 1.1.4, 1.0.6 - NuGet microsoft.aspnetcore.server.weblistener: affected >= 1.0.0, < 1.0.6; >= 1.1.0, < 1.1.4; fixed in 1.1.4, 1.0.6 ## Suggested inspection (read-only) - NuGet microsoft.aspnetcore.server.httpsys: check the installed version with your package manager. - NuGet microsoft.net.http.server: check the installed version with your package manager. - NuGet microsoft.aspnetcore.server.weblistener: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on microsoft.aspnetcore.server.httpsys, microsoft.net.http.server, microsoft.aspnetcore.server.weblistener. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-f9jc-rrm2-pmfg (GitHub-reviewed advisory GHSA-f9jc-rrm2-pmfg lists affected ranges: NuGet microsoft.aspnetcore.server.weblistener >=1.0.0 =1.1.0 =1.0.0 =1.1.0 =2.0.0 <2.0.2) Commands are suggestions: review each one before running it.
Loading voting…