Skip to content

← Public intelligence

NuGet package

microsoft.aspnetcore.signalr.protocols.messagepack

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

3 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 5.3NuGetAmendedPublished

    Microsoft Security Advisory CVE-2026-92707 - ASP.NET Core Denial of Service Vulnerability

    GHSA-86xp-94pg-8r6r

    Affected
    • NuGet microsoft.aspnetcore.signalr.protocols.messagepack >= 10.0.0, <= 10.0.12; >= 11.0.0-preview.5, <= 11.0.0-rc.1; >= 8.0.0, <= 8.0.31; >= 9.0.0, <= 9.0.20
    Fixed in
    11.0.0-rc.210.0.138.0.329.0.21· Vendor fix available
    Issue
    Executive summary Microsoft is releasing this security advisory to provide information about a vulnerability in Microsoft.AspNetCore.SignalR.Protocols.MessagePack; MessagePack; MessagePack.Annotations; MessagePackAnalyzer. This advisory also provides guidance on what developers can do to update their applications to remove this vulnerability. SignalR's MessagePack protocol can consume excessive memory while deserializing deeply nested attacker-controlled arrays, resulting in unauthenticated remote denial of service. Announcement Announcement for this issue can be found at https://github.com/dotnet/announcements/issues/473 CVSS Details - Version: 3.1 - Severity: Moderate - Score: 5.3 - Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L - Weakness: CWE-1325 (Improperly Controlled Sequential Memory Allocation) Affected Platforms - Platforms: Windows, Linux, macOS - Architectures: All <a name="affected-packages"</aAffected Packages The vulnerability affects Microsoft .NET projects that…

    Recommended action: Upgrade to 11.0.0-rc.2 (pre-release), 10.0.13, 9.0.21 or 8.0.32 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. High, CVSS 7.5NuGetPublished

    Microsoft Security Advisory CVE-2026-45591 – ASP.NET Core Denial of Service Vulnerability

    CVE-2026-45591 · GHSA-f8h2-vmm9-qhj6

    Affected
    • NuGet microsoft.aspnetcore.signalr.protocols.messagepack >= 8.0.0, <= 8.0.27; >= 9.0.0, <= 9.0.16; >= 10.0.0, <= 10.0.8
    Fixed in
    8.0.289.0.1710.0.9· Vendor fix available
    Issue
    Executive summary Microsoft is releasing this security advisory to provide information about a vulnerability in ASP.NET Core SignalR and Blazor Server. This advisory also provides guidance on what developers can do to update their applications to remove this vulnerability. A denial of service vulnerability exists in the MessagePack hub protocol used by SignalR and Blazor Server where an attacker can send deeply-nested MessagePack arrays to cause a stack overflow, resulting in a denial of service. Announcement Announcement for this issue can be found at https://github.com/dotnet/announcements/issues/405 Affected Platforms - Platforms: All - Architectures: All <a name="affected-packages"</aAffected Packages The vulnerability affects any Microsoft .NET project if it uses any of affected package versions listed below <a name=".NET 10"</a.NET 10 Package name | Affected version | Patched version ------------ | ---------------- | -------------------------…

    Recommended action: Upgrade to 10.0.9, 9.0.17 or 8.0.28 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. High, CVSS 7.5NuGetPublished

    Denial of service in ASP.NET Core

    CVE-2019-0982 · GHSA-4jxx-4qxw-prxm

    Affected
    • NuGet microsoft.aspnetcore.signalr.protocols.messagepack >= 1.1.0, < 1.1.5; >= 1.0.0, < 1.0.11
    Fixed in
    1.0.111.1.5· Vendor fix available
    Issue
    A denial of service vulnerability exists when ASP.NET Core improperly handles web requests, aka 'ASP.NET Core Denial of Service Vulnerability'.

    Recommended action: Upgrade to 1.1.5 or 1.0.11 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →