Skip to content

← Actionable
High, CVSS 7.5

Microsoft Security Advisory CVE-2026-45591 – ASP.NET Core Denial of Service Vulnerability

CVE-2026-45591GHSA-f8h2-vmm9-qhj6

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (microsoft.aspnetcore.signalr.protocols.messagepack 10.0.9, 9.0.17, 8.0.28; microsoft.aspnetcore.app.runtime.linux-x64 10.0.9, 9.0.17, 8.0.28; microsoft.aspnetcore.app.runtime.osx-arm64 10.0.9, 9.0.17, 8.0.28; microsoft.aspnetcore.app.runtime.win-x64 10.0.9, 9.0.17, 8.0.28), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-f8h2-vmm9-qhj6 lists affected ranges: NuGet microsoft.aspnetcore.app.runtime.linux-x64 >=8.0.0 =9.0.0 =10.0.0 =8.0.0 =9.0.0 =10.0.0 =8.0.0 =9.0.0 =10.0.0 =8.0.0 =9.0.0 =10.0.0 <=10.0.8

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-45591: 2.48% estimated exploitation activity in the next 30 days; percentile 84.60 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Executive summary Microsoft is releasing this security advisory to provide information about a vulnerability in ASP.NET Core SignalR and Blazor Server. This advisory also provides guidance on what developers can do to update their applications to remove this vulnerability. A denial of service vulnerability exists in the MessagePack hub protocol used by SignalR and Blazor Server where an attacker can send deeply-nested MessagePack arrays to cause a stack overflow, resulting in a denial of service. Announcement Announcement for this issue can be found at https://github.com/dotnet/announcements/issues/405 Affected Platforms - Platforms: All - Architectures: All <a name="affected-packages"</aAffected Packages The vulnerability affects any Microsoft .NET project if it uses any of affected package versions listed below <a name=".NET 10"</a.NET 10 Package name | Affected version | Patched version ------------ | ---------------- | -------------------------…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-f8h2-vmm9-qhj6

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-45591

Advisory: Microsoft Security Advisory CVE-2026-45591 – ASP.NET Core Denial of Service Vulnerability
IDs: CVE-2026-45591, GHSA-f8h2-vmm9-qhj6
Record: https://patchnext.com/advisories/cve-2026-45591 (revision 1, source checked 26 Oct 2026, 17:04 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: microsoft.aspnetcore.signalr.protocols.messagepack 10.0.9, 9.0.17, 8.0.28; microsoft.aspnetcore.app.runtime.linux-x64 10.0.9, 9.0.17, 8.0.28; microsoft.aspnetcore.app.runtime.osx-arm64 10.0.9, 9.0.17, 8.0.28; microsoft.aspnetcore.app.runtime.win-x64 10.0.9, 9.0.17, 8.0.28. A vendor fix does not mean a deployment is fixed.

## Affected components
- NuGet microsoft.aspnetcore.signalr.protocols.messagepack: affected >= 8.0.0, <= 8.0.27; >= 9.0.0, <= 9.0.16; >= 10.0.0, <= 10.0.8; fixed in 8.0.28, 9.0.17, 10.0.9
- NuGet microsoft.aspnetcore.app.runtime.linux-x64: affected >= 8.0.0, <= 8.0.27; >= 9.0.0, <= 9.0.16; >= 10.0.0, <= 10.0.8; fixed in 8.0.28, 9.0.17, 10.0.9
- NuGet microsoft.aspnetcore.app.runtime.osx-arm64: affected >= 8.0.0, <= 8.0.27; >= 9.0.0, <= 9.0.16; >= 10.0.0, <= 10.0.8; fixed in 8.0.28, 9.0.17, 10.0.9
- NuGet microsoft.aspnetcore.app.runtime.win-x64: affected >= 8.0.0, <= 8.0.27; >= 9.0.0, <= 9.0.16; >= 10.0.0, <= 10.0.8; fixed in 8.0.28, 9.0.17, 10.0.9

## Suggested inspection (read-only)
- NuGet microsoft.aspnetcore.signalr.protocols.messagepack: check the installed version with your package manager.
- NuGet microsoft.aspnetcore.app.runtime.linux-x64: check the installed version with your package manager.
- NuGet microsoft.aspnetcore.app.runtime.osx-arm64: check the installed version with your package manager.
- NuGet microsoft.aspnetcore.app.runtime.win-x64: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on microsoft.aspnetcore.signalr.protocols.messagepack, microsoft.aspnetcore.app.runtime.linux-x64, microsoft.aspnetcore.app.runtime.osx-arm64, microsoft.aspnetcore.app.runtime.win-x64.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-f8h2-vmm9-qhj6 (GitHub-reviewed advisory GHSA-f8h2-vmm9-qhj6 lists affected ranges: NuGet microsoft.aspnetcore.app.runtime.linux-x64 >=8.0.0 =9.0.0 =10.0.0 =8.0.0 =9.0.0 =10.0.0 =8.0.0 =9.0.0 =10.0.0 =8.0.0 =9.0.0 =10.0.0 <=10.0.8)

Commands are suggestions: review each one before running it.

Loading voting…