Skip to content

← Public intelligence

NuGet package

microsoft.aspnetcore.authentication.negotiate

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

3 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.5NuGetAmendedPublished

    Microsoft Security Advisory CVE-2026-70179 - ASP.NET Core Elevation of Privilege Vulnerability

    CVE-2026-70179 · GHSA-vrrp-6v32-2p8g

    Affected
    • NuGet microsoft.aspnetcore.authentication.negotiate >= 10.0.0, <= 10.0.12; >= 8.0.0, <= 8.0.31; >= 9.0.0, <= 9.0.20
    Fixed in
    10.0.138.0.329.0.21· Vendor fix available
    Issue
    Executive summary Microsoft is releasing this security advisory to provide information about a vulnerability in Microsoft.AspNetCore.Authentication.Negotiate. This advisory also provides guidance on what developers can do to update their applications to remove this vulnerability. ASP.NET Core Negotiate LDAP authentication can associate an authenticated identity with an unintended LDAP principal when the LDAP result is not verified against the Kerberos principal SID. Announcement Announcement for this issue can be found at https://github.com/dotnet/announcements/issues/458 CVSS Details - Version: 3.1 - Severity: High - Score: 7.5 - Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H - Weakness: CWE-290 (Authentication Bypass by Spoofing) Affected Platforms - Platforms: Windows, Linux, macOS when LDAP claim resolution is enabled - Architectures: All <a name="affected-packages"</aAffected Packages The vulnerability affects Microsoft .NET projects that use an affected package version…

    Recommended action: Upgrade to 10.0.13, 9.0.21 or 8.0.32 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. High, CVSS 8.8NuGetPublished

    Microsoft Security Advisory CVE-2026-47300 – .NET Elevation of Privilege Vulnerability

    CVE-2026-47300 · GHSA-8prm-248r-h957

    Affected
    • NuGet microsoft.aspnetcore.authentication.negotiate >= 10.0.0, <= 10.0.9; >= 9.0.0, <= 9.0.17; >= 8.0.0, <= 8.0.28
    Fixed in
    8.0.2910.0.109.0.18· Vendor fix available
    Issue
    Executive summary Microsoft is releasing this security advisory to provide information about a vulnerability in ASP.NET Core Negotiate Authentication (Microsoft.AspNetCore.Authentication.Negotiate). This advisory also provides guidance on what developers can do to update their applications to remove this vulnerability. An elevation of privilege vulnerability exists in the ASP.NET Core Negotiate authentication handler in .NET 8, .NET 9, and .NET 10 due to improper validation. Announcement Announcement for this issue can be found at https://github.com/dotnet/announcements/issues/TBD CVSS Details - Version: 3.1 - Severity: High - Score: 8.8 - Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Weakness: CWE-303 (Incorrect Implementation of Authentication Algorithm) Affected Platforms - Platforms: All - Architectures: All Mitigation Factors Your ASP.NET Core app is only affected if it uses Negotiate authentication and LDAP to retrieve role information. <a…

    Recommended action: Upgrade to 10.0.10, 9.0.18 or 8.0.29 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. High, CVSS 8.8NuGetPublished

    Microsoft Security Advisory CVE-2026-47303 – .NET Elevation of Privilege Vulnerability

    CVE-2026-47303 · GHSA-2p3q-h3hg-jcqq

    Affected
    • NuGet microsoft.aspnetcore.authentication.negotiate >= 10.0.0, <= 10.0.9; >= 9.0.0, <= 9.0.17; >= 8.0.0, <= 8.0.28
    Fixed in
    8.0.2910.0.109.0.18· Vendor fix available
    Issue
    Executive summary Microsoft is releasing this security advisory to provide information about a vulnerability in ASP.NET Core Negotiate Authentication (Microsoft.AspNetCore.Authentication.Negotiate). This advisory also provides guidance on what developers can do to update their applications to remove this vulnerability. An elevation of privilege vulnerability exists in the ASP.NET Core Negotiate authentication handler in .NET 8, .NET 9, and .NET 10 due to improper parsing. Announcement Announcement for this issue can be found at https://github.com/dotnet/announcements/issues/TBD CVSS Details - Version: 3.1 - Severity: High - Score: 8.8 - Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Weakness: CWE-302 (Authentication Bypass by Assumed-Immutable Data), CWE-863 (Incorrect Authorization), CWE-90 (Improper Neutralization of Special Elements used in an LDAP Query ('LDAP Injection')) Affected Platforms - Platforms: All - Architectures: All <a name="affected-packages"</aAffected…

    Recommended action: Upgrade to 10.0.10, 9.0.18 or 8.0.29 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →