Skip to content

← Actionable
High, CVSS 7.5amended

Microsoft Security Advisory CVE-2026-70179 - ASP.NET Core Elevation of Privilege Vulnerability

CVE-2026-70179GHSA-vrrp-6v32-2p8g

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (microsoft.aspnetcore.authentication.negotiate 10.0.13, 9.0.21, 8.0.32), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-70179: 0.63% estimated exploitation activity in the next 30 days; percentile 50.21 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Executive summary Microsoft is releasing this security advisory to provide information about a vulnerability in Microsoft.AspNetCore.Authentication.Negotiate. This advisory also provides guidance on what developers can do to update their applications to remove this vulnerability. ASP.NET Core Negotiate LDAP authentication can associate an authenticated identity with an unintended LDAP principal when the LDAP result is not verified against the Kerberos principal SID. Announcement Announcement for this issue can be found at https://github.com/dotnet/announcements/issues/458 CVSS Details - Version: 3.1 - Severity: High - Score: 7.5 - Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H - Weakness: CWE-290 (Authentication Bypass by Spoofing) Affected Platforms - Platforms: Windows, Linux, macOS when LDAP claim resolution is enabled - Architectures: All <a name="affected-packages"</aAffected Packages The vulnerability affects Microsoft .NET projects that use an affected package version…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-vrrp-6v32-2p8g

  2. Revision 1 · created ·

    Published from osv record GHSA-vrrp-6v32-2p8g

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-70179

Advisory: Microsoft Security Advisory CVE-2026-70179 - ASP.NET Core Elevation of Privilege Vulnerability
IDs: CVE-2026-70179, GHSA-vrrp-6v32-2p8g
Record: https://patchnext.com/advisories/cve-2026-70179 (revision 2, source checked 26 Oct 2026, 17:05 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: microsoft.aspnetcore.authentication.negotiate 10.0.13, 9.0.21, 8.0.32. A vendor fix does not mean a deployment is fixed.

## Affected components
- NuGet microsoft.aspnetcore.authentication.negotiate: affected >= 10.0.0, <= 10.0.12; >= 8.0.0, <= 8.0.31; >= 9.0.0, <= 9.0.20; fixed in 10.0.13, 8.0.32, 9.0.21

## Suggested inspection (read-only)
- NuGet microsoft.aspnetcore.authentication.negotiate: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on microsoft.aspnetcore.authentication.negotiate.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-vrrp-6v32-2p8g (OSV record GHSA-vrrp-6v32-2p8g lists affected ranges: NuGet microsoft.aspnetcore.authentication.negotiate >=10.0.0 =8.0.0 =9.0.0 <9.0.21 (fixed))
- Verified: https://github.com/advisories/GHSA-vrrp-6v32-2p8g (GitHub-reviewed advisory GHSA-vrrp-6v32-2p8g lists affected ranges: NuGet microsoft.aspnetcore.authentication.negotiate >=10.0.0 =8.0.0 =9.0.0 <=9.0.20)

Commands are suggestions: review each one before running it.

Loading voting…