Skip to content

← Public intelligence

NuGet package

dotnetnuke.core

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

32 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.5NuGetPublished

    Insufficient Entropy in DotNetNuke

    CVE-2018-18326 · GHSA-xx3h-j3cx-8qfj

    Affected
    • NuGet dotnetnuke.core < 9.3.0
    Fixed in
    9.3.0· Vendor fix available
    Issue
    DNN (aka DotNetNuke) 9.2 through 9.2.2 incorrectly converts encryption key source values, resulting in lower than expected entropy. NOTE: this issue exists because of an incomplete fix for CVE-2018-15812.

    Recommended action: Upgrade to 9.3.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. High, CVSS 7.5Exploited · CISA KEVNuGetPublished

    Inadequate Encryption Strength in DotNetNuke

    CVE-2018-18325 · GHSA-j3g9-6fx5-gjv7

    Affected
    • NuGet dotnetnuke.core < 9.3.0
    Fixed in
    9.3.0· Vendor fix available
    Issue
    DNN (aka DotNetNuke) 9.2 through 9.2.2 uses a weak encryption algorithm to protect input parameters. NOTE: this issue exists because of an incomplete fix for CVE-2018-15811.

    Recommended action: Upgrade to 9.3.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.com (1)cisa.gov (2)Source checked Evidence →
  3. High, CVSS 8.8Exploited · CISA KEVNuGetPublished

    DNN (aka DotNetNuke) has Remote Code Execution via a cookie

    CVE-2017-9822 · GHSA-x2rg-fmcv-crq5

    Affected
    • NuGet dotnetnuke.core < 9.1.1
    Fixed in
    9.1.1· Vendor fix available
    Issue
    DNN (aka DotNetNuke) before 9.1.1 has Remote Code Execution via a cookie, aka "2017-08 (Critical) Possible remote code execution on DNN sites."

    Recommended action: Upgrade to 9.1.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.com (1)cisa.gov (2)Source checked Evidence →
  4. Medium, CVSS 5.4NuGetPublished

    Cross-site scripting (XSS) vulnerability in the user-profile biography section in DotNetNuke (DNN)

    CVE-2016-7119 · GHSA-5c66-x4wm-rjfx

    Affected
    • NuGet dotnetnuke.core < 8.0.1
    Fixed in
    8.0.1· Vendor fix available
    Issue
    Cross-site scripting (XSS) vulnerability in the user-profile biography section in DotNetNuke (DNN) before 8.0.1 allows remote authenticated users to inject arbitrary web script or HTML via a crafted onclick attribute in an IMG element.

    Recommended action: Upgrade to 8.0.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  5. Critical, CVSS 9.8NuGetPublished

    The installation wizard in DotNetNuke (DNN) allows privilege escalation

    CVE-2015-2794 · GHSA-x8f7-h444-97w4

    Affected
    • NuGet dotnetnuke.core < 7.4.1
    Fixed in
    7.4.1· Vendor fix available
    Issue
    The installation wizard in DotNetNuke (DNN) before 7.4.1 allows remote attackers to reinstall the application and gain SuperUser access via a direct request to Install/InstallWizard.aspx.

    Recommended action: Upgrade to 7.4.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  6. UnratedNuGetPublished

    Moderate severity vulnerability that affects DotNetNuke.Core

    CVE-2015-1566 · GHSA-v76m-f5cx-8rg4

    Affected
    • NuGet dotnetnuke.core < 7.4.0
    Fixed in
    7.4.0· Vendor fix available
    Issue
    Cross-site scripting (XSS) vulnerability in DotNetNuke (DNN) before 7.4.0 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.

    Recommended action: Upgrade to 7.4.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  7. High, CVSS 7.5NuGetPublished

    High severity vulnerability that affects DotNetNuke.Core

    CVE-2017-0929 · GHSA-g8j6-m4p7-5rfq

    Affected
    • NuGet dotnetnuke.core < 9.2.0
    Fixed in
    9.2.0· Vendor fix available
    Issue
    DNN (aka DotNetNuke) before 9.2.0 suffers from a Server-Side Request Forgery (SSRF) vulnerability in the DnnImageHandler class. Attackers may be able to access information about internal network resources.

    Recommended action: Upgrade to 9.2.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →