Inadequate Encryption Strength in DotNetNuke
CVE-2018-18325GHSA-j3g9-6fx5-gjv7
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (dotnetnuke.core 9.3.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
NuGet dotnetnuke.core
- Affected
- < 9.3.0
- Fixed in
- 9.3.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-j3g9-6fx5-gjv7 lists affected ranges: NuGet dotnetnuke.core >=0 <9.3.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- CISA Known Exploited Vulnerabilities Catalog
CISA added CVE-2018-18325 to the Known Exploited Vulnerabilities catalog on 2021-11-03.
VerifiedObserved Listed in the CISA KEV JSON feed (dateAdded 2021-11-03).
Severity and exploitation
- Exploitation
- Confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
- CVSS
- 7.5 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N/E:H
- EPSS
- CVE-2018-18325: 74.05% estimated exploitation activity in the next 30 days; percentile 99.48 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
DNN (aka DotNetNuke) 9.2 through 9.2.2 uses a weak encryption algorithm to protect input parameters. NOTE: this issue exists because of an incomplete fix for CVE-2018-15811.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-j3g9-6fx5-gjv7
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2018-18325 Advisory: Inadequate Encryption Strength in DotNetNuke IDs: CVE-2018-18325, GHSA-j3g9-6fx5-gjv7 Record: https://patchnext.com/advisories/cve-2018-18325 (revision 1, source checked 26 Oct 2026, 17:04 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: confirmed: listed in the CISA Known Exploited Vulnerabilities catalog. Vendor response: Vendor fix available; fixed versions by package: dotnetnuke.core 9.3.0. A vendor fix does not mean a deployment is fixed. ## Affected components - NuGet dotnetnuke.core: affected < 9.3.0; fixed in 9.3.0 ## Suggested inspection (read-only) - NuGet dotnetnuke.core: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on dotnetnuke.core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-j3g9-6fx5-gjv7 (GitHub-reviewed advisory GHSA-j3g9-6fx5-gjv7 lists affected ranges: NuGet dotnetnuke.core >=0 <9.3.0) - Verified: https://www.cisa.gov/known-exploited-vulnerabilities-catalog (CISA added CVE-2018-18325 to the Known Exploited Vulnerabilities catalog on 2021-11-03.) Commands are suggestions: review each one before running it.
Loading voting…