Skip to content

← Public intelligence

Maven package

struts:struts

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

4 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. UnratedMavenPublished

    Apache Struts Cross-site Scripting vulnerability

    CVE-2008-2025 · GHSA-wcgx-2hvx-5cwr

    Affected
    • Maven struts:struts < 1.2.9-162.31.1
    Fixed in
    1.2.9-162.31.1· Vendor fix available
    Issue
    Cross-site scripting (XSS) vulnerability in Apache Struts before 1.2.9-162.31.1 on SUSE Linux Enterprise (SLE) 11, before 1.2.9-108.2 on SUSE openSUSE 10.3, before 1.2.9-198.2 on SUSE openSUSE 11.0, and before 1.2.9-162.163.2 on SUSE openSUSE 11.1 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors related to "insufficient quoting of parameters."

    Recommended action: Upgrade to 1.2.9-162.31.1 (pre-release) or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. High, CVSS 7.5Exploited · CISA KEVMavenPublished

    Improper Input Validation in Apache Struts

    CVE-2006-1547 · GHSA-7qwv-cwgj-c8rj

    Affected
    • Maven struts:struts < 1.2.9
    Fixed in
    1.2.9· Vendor fix available
    Issue
    ActionForm in Apache Software Foundation (ASF) Struts before 1.2.9 with BeanUtils 1.7 allows remote attackers to cause a denial of service via a multipart/form-data encoded form with a parameter name that references the public getMultipartRequestHandler method, which provides further access to elements in the CommonsMultipartRequestHandler implementation and BeanUtils.

    Recommended action: Upgrade to 1.2.9 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.com (1)cisa.gov (2)Source checked Evidence →
  3. High, CVSS 7.3MavenPublished

    Apache Struts vulnerable to Improper Input Validation

    CVE-2006-1546 · GHSA-vf8g-mpmw-qv87

    Affected
    • Maven struts:struts < 1.2.9
    Fixed in
    1.2.9· Vendor fix available
    Issue
    Apache Software Foundation (ASF) Struts before 1.2.9 allows remote attackers to bypass validation via a request with a 'org.apache.struts.taglib.html.Constants.CANCEL' parameter, which causes the action to be canceled but would not be detected from applications that do not use the isCancelled check.

    Recommended action: Upgrade to 1.2.9 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  4. Low, CVSS 3.7MavenPublished

    Cross-site scripting in Apache Struts

    CVE-2006-1548 · GHSA-p3vw-fvwx-qcv5

    Affected
    • Maven struts:struts < 1.2.9
    Fixed in
    1.2.9· Vendor fix available
    Issue
    Cross-site scripting (XSS) vulnerability in (1) LookupDispatchAction and possibly (2) DispatchAction and (3) ActionDispatcher in Apache Software Foundation (ASF) Struts before 1.2.9 allows remote attackers to inject arbitrary web script or HTML via the parameter name, which is not filtered in the resulting error message.

    Recommended action: Upgrade to 1.2.9 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →