Skip to content

← Actionable
High, CVSS 7.5Exploited · CISA KEV

Improper Input Validation in Apache Struts

CVE-2006-1547GHSA-7qwv-cwgj-c8rj

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (struts:struts 1.2.9), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
Confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H/E:H
EPSS
  • CVE-2006-1547: 54.63% estimated exploitation activity in the next 30 days; percentile 99.02 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

ActionForm in Apache Software Foundation (ASF) Struts before 1.2.9 with BeanUtils 1.7 allows remote attackers to cause a denial of service via a multipart/form-data encoded form with a parameter name that references the public getMultipartRequestHandler method, which provides further access to elements in the CommonsMultipartRequestHandler implementation and BeanUtils.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-7qwv-cwgj-c8rj

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2006-1547

Advisory: Improper Input Validation in Apache Struts
IDs: CVE-2006-1547, GHSA-7qwv-cwgj-c8rj
Record: https://patchnext.com/advisories/cve-2006-1547 (revision 1, source checked 26 Oct 2026, 16:40 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
Vendor response: Vendor fix available; fixed versions by package: struts:struts 1.2.9. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven struts:struts: affected < 1.2.9; fixed in 1.2.9

## Suggested inspection (read-only)
- Maven struts:struts: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on struts:struts.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-7qwv-cwgj-c8rj (GitHub-reviewed advisory GHSA-7qwv-cwgj-c8rj lists affected ranges: Maven struts:struts >=0 <1.2.9)
- Verified: https://www.cisa.gov/known-exploited-vulnerabilities-catalog (CISA added CVE-2006-1547 to the Known Exploited Vulnerabilities catalog on 2022-01-21.)

Commands are suggestions: review each one before running it.

Loading voting…