Skip to content

← Public intelligence

Maven package

software.amazon.jdbc:aws-advanced-jdbc-wrapper

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 8.6MavenPublished

    AWS-JDBC Wrapper: Privilege Escalation in Aurora PostgreSQL instance

    CVE-2026-11400 · GHSA-mhww-p97m-3368

    Affected
    • Maven software.amazon.jdbc:aws-advanced-jdbc-wrapper >= 3.0.0, < 4.0.1
    Fixed in
    4.0.1· Vendor fix available
    Issue
    Aurora PostgreSQL is a fully managed relational database engine that's compatible with PostgreSQL. The team has identified CVE-2026-11400, an issue in Aurora PostgreSQL using the AWS Advanced JDBC Wrapper Impact An issue in AWS Wrappers for Amazon Aurora PostgreSQL will allow for privilege escalation to rdssuperuser role. A low privilege authenticated user can create a crafted function that could be executed with permissions of other Amazon Relational Database Service (RDS) users. Impacted versions: AWS Advanced JDBC Wrapper = 3.0.0 and < 4.0.1 Patches This issue has been addressed in AWS JDBC Wrapper v4.0.1. It is recommended to upgrade to the latest version and ensuring any forked or derivative code is patched to incorporate the new fixes. Workarounds Remove the public schema from the search path. Resources If there are any questions or comments about this advisory, contact [AWS/Amazon] Security via vulnerability reporting page or directly via email to aws-security@amazon.com.…

    Recommended action: Upgrade to 4.0.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. High, CVSS 8.0MavenPublished

    Amazon Web Services Advanced JDBC Wrapper: Privilege Escalation in Aurora PostgreSQL instance

    GHSA-7xw4-g7mm-r4hh

    Affected
    • Maven software.amazon.jdbc:aws-advanced-jdbc-wrapper <= 2.6.4
    Fixed in
    2.6.5· Vendor fix available
    Issue
    of Vulnerability: An issue in AWS Wrappers for Amazon Aurora PostgreSQL may allow for privilege escalation to rdssuperuser role. A low privilege authenticated user can create a crafted function that could be executed with permissions of other Amazon Relational Database Service (RDS) users. AWS recommends for customers to upgrade to the following versions: AWS JDBC Wrapper to v2.6.5 or greater. Source of Vulnerability Report: Allistair Ishmael Hakim allistair.hakim@gmail.com Affected products & versions: AWS JDBC Wrapper < 2.6.5 Platforms: MacOS/Windows/Linux

    Recommended action: Upgrade to 2.6.5 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →