Skip to content

← Actionable
High, CVSS 8.0

Amazon Web Services Advanced JDBC Wrapper: Privilege Escalation in Aurora PostgreSQL instance

GHSA-7xw4-g7mm-r4hh

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (software.amazon.jdbc:aws-advanced-jdbc-wrapper 2.6.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.0 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Description of Vulnerability: An issue in AWS Wrappers for Amazon Aurora PostgreSQL may allow for privilege escalation to rdssuperuser role. A low privilege authenticated user can create a crafted function that could be executed with permissions of other Amazon Relational Database Service (RDS) users. AWS recommends for customers to upgrade to the following versions: AWS JDBC Wrapper to v2.6.5 or greater. Source of Vulnerability Report: Allistair Ishmael Hakim allistair.hakim@gmail.com Affected products & versions: AWS JDBC Wrapper < 2.6.5 Platforms: MacOS/Windows/Linux

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-7xw4-g7mm-r4hh

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-7xw4-g7mm-r4hh

Advisory: Amazon Web Services Advanced JDBC Wrapper: Privilege Escalation in Aurora PostgreSQL instance
IDs: GHSA-7xw4-g7mm-r4hh
Record: https://patchnext.com/advisories/ghsa-7xw4-g7mm-r4hh (revision 1, source checked 26 Oct 2026, 16:41 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: software.amazon.jdbc:aws-advanced-jdbc-wrapper 2.6.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven software.amazon.jdbc:aws-advanced-jdbc-wrapper: affected <= 2.6.4; fixed in 2.6.5

## Suggested inspection (read-only)
- Maven software.amazon.jdbc:aws-advanced-jdbc-wrapper: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on software.amazon.jdbc:aws-advanced-jdbc-wrapper.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-7xw4-g7mm-r4hh (GitHub-reviewed advisory GHSA-7xw4-g7mm-r4hh lists affected ranges: Maven software.amazon.jdbc:aws-advanced-jdbc-wrapper >=0 <=2.6.4)

Commands are suggestions: review each one before running it.

Loading voting…