Critical, CVSS 9.8MavenPublished
Pippo RCE Vulnerability
CVE-2018-18240 · GHSA-h892-x453-86wc
- Affected
- Maven ro.pippo:pippo-session <= 1.11.0
- Fixed in
- 1.12.0· Vendor fix available
- Issue
- Pippo through 1.11.0 allows remote code execution via a command to java.lang.ProcessBuilder because the XstreamEngine component does not use XStream's available protection mechanisms to restrict unmarshalling.
Recommended action: Upgrade to 1.12.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.