Pippo RCE Vulnerability
CVE-2018-18240GHSA-h892-x453-86wc
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (ro.pippo:pippo-core 1.12.0; ro.pippo:pippo-session 1.12.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven ro.pippo:pippo-core
- Affected
- <= 1.11.0
- Fixed in
- 1.12.0
Maven ro.pippo:pippo-session
- Affected
- <= 1.11.0
- Fixed in
- 1.12.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-h892-x453-86wc lists affected ranges: Maven ro.pippo:pippo-core >=0 =0 <=1.11.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2018-18240: 3.65% estimated exploitation activity in the next 30 days; percentile 89.63 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Pippo through 1.11.0 allows remote code execution via a command to java.lang.ProcessBuilder because the XstreamEngine component does not use XStream's available protection mechanisms to restrict unmarshalling.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-h892-x453-86wc
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2018-18240 Advisory: Pippo RCE Vulnerability IDs: CVE-2018-18240, GHSA-h892-x453-86wc Record: https://patchnext.com/advisories/cve-2018-18240 (revision 1, source checked 26 Oct 2026, 16:14 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: ro.pippo:pippo-core 1.12.0; ro.pippo:pippo-session 1.12.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven ro.pippo:pippo-core: affected <= 1.11.0; fixed in 1.12.0 - Maven ro.pippo:pippo-session: affected <= 1.11.0; fixed in 1.12.0 ## Suggested inspection (read-only) - Maven ro.pippo:pippo-core: check the installed version with your package manager. - Maven ro.pippo:pippo-session: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on ro.pippo:pippo-core, ro.pippo:pippo-session. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-h892-x453-86wc (GitHub-reviewed advisory GHSA-h892-x453-86wc lists affected ranges: Maven ro.pippo:pippo-core >=0 =0 <=1.11.0) Commands are suggestions: review each one before running it.
Loading voting…