High, CVSS 7.5Exploited · CISA KEVMavenPublished
ZK Framework vulnerable to malicious POST
CVE-2022-36537 · GHSA-6278-2q4m-cmf3
- Affected
- Maven org.zkoss.zk:zk < 8.6.4.2; >= 9.0.0.0, < 9.0.1.3; >= 9.5.0.0, < 9.5.1.4; >= 9.6.0.0, < 9.6.0.2; >= 9.6.1, < 9.6.2
- Fixed in
- 8.6.4.29.6.29.0.1.39.5.1.49.6.0.2· Vendor fix available
- Issue
- ZK Framework version 9.6.1, 9.6.0.1, 9.5.1.3, 9.0.1.2 and 8.6.4.1 allows attackers to access sensitive information via a crafted POST request sent to the component AuUploader.
Recommended action: Upgrade to 9.6.2, 9.6.0.2, 9.5.1.4 or 2 more by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.