Skip to content

← Actionable
High, CVSS 7.5Exploited · CISA KEV

ZK Framework vulnerable to malicious POST

CVE-2022-36537GHSA-6278-2q4m-cmf3

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.zkoss.zk:zk 9.6.2, 9.6.0.2, 9.5.1.4, 9.0.1.3, 8.6.4.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Maven org.zkoss.zk:zk

    Affected
    < 8.6.4.2>= 9.0.0.0, < 9.0.1.3>= 9.5.0.0, < 9.5.1.4>= 9.6.0.0, < 9.6.0.2>= 9.6.1, < 9.6.2
    Fixed in
    8.6.4.2, 9.6.2, 9.0.1.3, 9.5.1.4, 9.6.0.2

Sources

Severity and exploitation
Exploitation
Confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N/E:H
EPSS
  • CVE-2022-36537: 95.40% estimated exploitation activity in the next 30 days; percentile 99.87 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

ZK Framework version 9.6.1, 9.6.0.1, 9.5.1.3, 9.0.1.2 and 8.6.4.1 allows attackers to access sensitive information via a crafted POST request sent to the component AuUploader.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-6278-2q4m-cmf3

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-36537

Advisory: ZK Framework vulnerable to malicious POST
IDs: CVE-2022-36537, GHSA-6278-2q4m-cmf3
Record: https://patchnext.com/advisories/cve-2022-36537 (revision 1, source checked 26 Oct 2026, 16:40 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
Vendor response: Vendor fix available; fixed versions by package: org.zkoss.zk:zk 9.6.2, 9.6.0.2, 9.5.1.4, 9.0.1.3, 8.6.4.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.zkoss.zk:zk: affected < 8.6.4.2; >= 9.0.0.0, < 9.0.1.3; >= 9.5.0.0, < 9.5.1.4; >= 9.6.0.0, < 9.6.0.2; >= 9.6.1, < 9.6.2; fixed in 8.6.4.2, 9.6.2, 9.0.1.3, 9.5.1.4, 9.6.0.2

## Suggested inspection (read-only)
- Maven org.zkoss.zk:zk: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.zkoss.zk:zk.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://www.cisa.gov/known-exploited-vulnerabilities-catalog (CISA added CVE-2022-36537 to the Known Exploited Vulnerabilities catalog on 2023-02-27.)
- Verified: https://github.com/advisories/GHSA-6278-2q4m-cmf3 (GitHub-reviewed advisory GHSA-6278-2q4m-cmf3 lists affected ranges: Maven org.zkoss.zk:zk >=0 =9.0.0.0 =9.5.0.0 =9.6.0.0 =9.6.1 <9.6.2)

Commands are suggestions: review each one before running it.

Loading voting…