Skip to content

← Public intelligence

Maven package

org.yamcs:yamcs

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

4 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 5.4MavenPublished

    Yamcs Cross-site Scripting vulnerability

    CVE-2023-45280 · GHSA-643f-hpcc-2gv8

    Affected
    • Maven org.yamcs:yamcs < 5.8.7
    Fixed in
    5.8.7· Vendor fix available
    Issue
    Yamcs 5.8.6 allows XSS (issue 2 of 2). It comes with a Bucket as its primary storage mechanism. Buckets allow for the upload of any file. There's a way to upload an HTML file containing arbitrary JavaScript and then navigate to it. Once the user opens the file, the browser will execute the arbitrary JavaScript.

    Recommended action: Upgrade to 5.8.7 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Medium, CVSS 5.4MavenPublished

    Yamcs Cross-site Scripting vulnerability

    CVE-2023-45279 · GHSA-4cqv-q33x-wfxw

    Affected
    • Maven org.yamcs:yamcs < 5.8.7
    Fixed in
    5.8.7· Vendor fix available
    Issue
    Yamcs 5.8.6 allows XSS (issue 1 of 2). It comes with a Bucket as its primary storage mechanism. Buckets allow for the upload of any file. There's a way to upload a display referencing a malicious JavaScript file to the bucket. The user can then open the uploaded display by selecting Telemetry from the menu and navigating to the display.

    Recommended action: Upgrade to 5.8.7 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. Critical, CVSS 9.1MavenPublished

    Yamcs API Directory Traversal vulnerability

    CVE-2023-45278 · GHSA-43fw-536j-w37j

    Affected
    • Maven org.yamcs:yamcs < 5.8.7
    Fixed in
    5.8.7· Vendor fix available
    Issue
    Directory Traversal vulnerability in the storage functionality of the API in Yamcs 5.8.6 allows attackers to delete arbitrary files via crafted HTTP DELETE request.

    Recommended action: Upgrade to 5.8.7 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  4. High, CVSS 7.5MavenPublished

    Yamcs Path Traversal vulnerability

    CVE-2023-45277 · GHSA-w4m2-qmh3-2g8f

    Affected
    • Maven org.yamcs:yamcs < 5.8.7
    Fixed in
    5.8.7· Vendor fix available
    Issue
    Yamcs 5.8.6 is vulnerable to directory traversal (issue 1 of 2). The vulnerability is in the storage functionality of the API and allows one to escape the base directory of the buckets, freely navigate system directories, and read arbitrary files.

    Recommended action: Upgrade to 5.8.7 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →