Yamcs Cross-site Scripting vulnerability
CVE-2023-45280GHSA-643f-hpcc-2gv8
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.yamcs:yamcs 5.8.7), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.yamcs:yamcs
- Affected
- < 5.8.7
- Fixed in
- 5.8.7
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-643f-hpcc-2gv8 lists affected ranges: Maven org.yamcs:yamcs >=0 <5.8.7
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.4 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2023-45280: 0.61% estimated exploitation activity in the next 30 days; percentile 49.18 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Yamcs 5.8.6 allows XSS (issue 2 of 2). It comes with a Bucket as its primary storage mechanism. Buckets allow for the upload of any file. There's a way to upload an HTML file containing arbitrary JavaScript and then navigate to it. Once the user opens the file, the browser will execute the arbitrary JavaScript.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-643f-hpcc-2gv8
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-45280 Advisory: Yamcs Cross-site Scripting vulnerability IDs: CVE-2023-45280, GHSA-643f-hpcc-2gv8 Record: https://patchnext.com/advisories/cve-2023-45280 (revision 1, source checked 26 Oct 2026, 16:16 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.yamcs:yamcs 5.8.7. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.yamcs:yamcs: affected < 5.8.7; fixed in 5.8.7 ## Suggested inspection (read-only) - Maven org.yamcs:yamcs: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.yamcs:yamcs. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-643f-hpcc-2gv8 (GitHub-reviewed advisory GHSA-643f-hpcc-2gv8 lists affected ranges: Maven org.yamcs:yamcs >=0 <5.8.7) Commands are suggestions: review each one before running it.
Loading voting…