Skip to content

← Public intelligence

Maven package

org.wildfly:wildfly-parent

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

6 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 5.9MavenPublished

    Wildfly has a memory leak vulnerability

    CVE-2020-27822 · GHSA-qx3p-9mmp-4v8h

    Affected
    • Maven org.wildfly:wildfly-parent >= 19.0.0.Final, < 21.0.2.Final; >= 22.0.0.Alpha1, <= 22.0.0.Alpha1
    Fixed in
    21.0.2.Final22.0.0.Beta1· Vendor fix available
    Issue
    A flaw was found in Wildfly affecting versions 19.0.0.Final, 19.1.0.Final, 20.0.0.Final, 20.0.1.Final, and 21.0.0.Final. When an application uses the OpenTracing API's java-interceptors, there is a possibility of a memory leak. This flaw allows an attacker to impact the availability of the server. The highest threat from this vulnerability is to system availability.

    Recommended action: Upgrade to 22.0.0.Beta1 or 21.0.2.Final by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. High, CVSS 7.5MavenPublished

    Wildfly Unsafe Deserialization Vulnerability

    CVE-2020-10740 · GHSA-vrmw-2xhq-hrmp

    Affected
    • Maven org.wildfly:wildfly-parent < 20.0.0.Final
    Fixed in
    20.0.0.Final· Vendor fix available
    Issue
    A vulnerability was found in Wildfly in versions before 20.0.0.Final, where a remote deserialization attack is possible in the Enterprise Application Beans(EJB) due to lack of validation/filtering capabilities in wildfly.

    Recommended action: Upgrade to 20.0.0.Final or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. High, CVSS 7.5MavenPublished

    The Undertow module of WildFly allows source code disclosure

    CVE-2015-3198 · GHSA-4vwv-x3gp-2j4g

    Affected
    • Maven org.wildfly:wildfly-parent >= 8.1.0.Final, <= 9.0.0.CR1
    Fixed in
    9.0.0.CR2· Vendor fix available
    Issue
    The Undertow module of WildFly versions 8.1.0.Final, 8.2.0.Final, 9.0.0.CR1 allows remote attackers to obtain the source code of a JSP page via a "/" at the end of a URL.

    Recommended action: Upgrade to 9.0.0.CR2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  4. High, CVSS 7.5MavenPublished

    WildFly has incomplete blacklist vulnerability

    CVE-2016-0793 · GHSA-9q87-22gr-r8qf

    Affected
    • Maven org.wildfly:wildfly-parent < 10.0.0.Final
    Fixed in
    10.0.0.Final· Vendor fix available
    Issue
    Incomplete blacklist vulnerability in the servlet filter restriction mechanism in WildFly (formerly JBoss Application Server) before 10.0.0.Final on Windows allows remote attackers to read the sensitive files in the (1) WEB-INF or (2) META-INF directory via a request that contains (a) lowercase or (b) "meaningless" characters.

    Recommended action: Upgrade to 10.0.0.Final or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  5. Medium, CVSS 5.3MavenPublished

    Wildfly logs plaintext passwords

    CVE-2020-25640 · GHSA-jw3v-5ch2-wfmm

    Affected
    • Maven org.wildfly:wildfly-parent < 21.0.0.Final
    Fixed in
    21.0.0.Final· Vendor fix available
    Issue
    A flaw was discovered in WildFly before 21.0.0.Final where, Resource adapter logs plain text JMS password at warning level on connection error, inserting sensitive information in the log file.

    Recommended action: Upgrade to 21.0.0.Final or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  6. Low, CVSS 3.8MavenPublished

    Cross-site Scripting in Wildfly

    CVE-2021-3536 · GHSA-v2wx-jj66-2hp7

    Affected
    • Maven org.wildfly:wildfly-parent <= 23.0.1.Final
    Fixed in
    23.0.2.Final· Vendor fix available
    Issue
    A flaw was found in Wildfly in versions before 23.0.2.Final while creating a new role in domain mode via the admin console, it is possible to add a payload in the name field, leading to XSS. This affects Confidentiality and Integrity.

    Recommended action: Upgrade to 23.0.2.Final or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →