WildFly has incomplete blacklist vulnerability
CVE-2016-0793GHSA-9q87-22gr-r8qf
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.wildfly:wildfly-undertow 10.0.0.Final; org.wildfly:wildfly-parent 10.0.0.Final), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.wildfly:wildfly-undertow
- Affected
- < 10.0.0.Final
- Fixed in
- 10.0.0.Final
Maven org.wildfly:wildfly-parent
- Affected
- < 10.0.0.Final
- Fixed in
- 10.0.0.Final
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9q87-22gr-r8qf lists affected ranges: Maven org.wildfly:wildfly-parent >=0 =0 <10.0.0.Final
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2016-0793: 14.97% estimated exploitation activity in the next 30 days; percentile 96.72 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Incomplete blacklist vulnerability in the servlet filter restriction mechanism in WildFly (formerly JBoss Application Server) before 10.0.0.Final on Windows allows remote attackers to read the sensitive files in the (1) WEB-INF or (2) META-INF directory via a request that contains (a) lowercase or (b) "meaningless" characters.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-9q87-22gr-r8qf
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2016-0793 Advisory: WildFly has incomplete blacklist vulnerability IDs: CVE-2016-0793, GHSA-9q87-22gr-r8qf Record: https://patchnext.com/advisories/cve-2016-0793 (revision 1, source checked 26 Oct 2026, 16:35 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.wildfly:wildfly-undertow 10.0.0.Final; org.wildfly:wildfly-parent 10.0.0.Final. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.wildfly:wildfly-undertow: affected < 10.0.0.Final; fixed in 10.0.0.Final - Maven org.wildfly:wildfly-parent: affected < 10.0.0.Final; fixed in 10.0.0.Final ## Suggested inspection (read-only) - Maven org.wildfly:wildfly-undertow: check the installed version with your package manager. - Maven org.wildfly:wildfly-parent: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.wildfly:wildfly-undertow, org.wildfly:wildfly-parent. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-9q87-22gr-r8qf (GitHub-reviewed advisory GHSA-9q87-22gr-r8qf lists affected ranges: Maven org.wildfly:wildfly-parent >=0 =0 <10.0.0.Final) Commands are suggestions: review each one before running it.
Loading voting…