Skip to content

← Public intelligence

Maven package

org.springframework.security:spring-security-saml2-service-provider

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

4 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.5MavenPublished

    Spring Security SAML2 Service Provider: Unbounded writer inflates the compressed SAML payload into memory (DoS)

    CVE-2026-40988 · GHSA-m69x-pw9p-7j3q

    Affected
    • Maven org.springframework.security:spring-security-saml2-service-provider >= 7.0.0, <= 7.0.5; >= 6.5.0, <= 6.5.10; >= 6.4.0, <= 6.4.16; >= 6.3.0, <= 6.3.16; >= 5.8.0, <= 5.8.25; <= 5.7.23
    Fixed in
    6.5.117.0.6· Partial vendor fix
    Issue
    An application using spring-security-saml2-service-provider and the REDIRECT binding for SAML 2.0 Login or Logout may be vulnerable to a denial of service by way of an unbounded writer that inflates the compressed SAML payload into memory. Affected versions: Spring Security 5.7.0 through 5.7.23; 5.8.0 through 5.8.25; 6.3.0 through 6.3.16; 6.4.0 through 6.4.16; 6.5.0 through 6.5.10; 7.0.0 through 7.0.5.

    Recommended action: Upgrade to 7.0.6 or 6.5.11 by release line; some affected versions have no fix yet, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. High, CVSS 7.6MavenPublished

    Spring Security SAML2 Service Provider: RelyingPartyRegistration may run arbitrary code on HTML forms generated by Spring Security filters

    CVE-2026-41003 · GHSA-3pjj-qpw6-5fcm

    Affected
    • Maven org.springframework.security:spring-security-saml2-service-provider >= 7.0.0, <= 7.0.5; >= 6.5.0, <= 6.5.10; >= 6.4.0, <= 6.4.16; >= 6.3.0, <= 6.3.16; >= 5.8.0, <= 5.8.25; <= 5.7.23
    Fixed in
    6.5.117.0.6· Partial vendor fix
    Issue
    An attacker able to influence values in RelyingPartyRegistration may be able to run arbitrary code on HTML forms generated by Spring Security filters. Affected versions: Spring Security 5.7.0 through 5.7.23; 5.8.0 through 5.8.25; 6.3.0 through 6.3.16; 6.4.0 through 6.4.16; 6.5.0 through 6.5.10; 7.0.0 through 7.0.5.

    Recommended action: Upgrade to 7.0.6 or 6.5.11 by release line; some affected versions have no fix yet, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. High, CVSS 7.3MavenPublished

    Spring Security SAML2 Service Provider is vulnerable to Deserialization of Untrusted Data via JdbcAssertingPartyMetadataRepository

    CVE-2026-40993 · GHSA-2q7c-5gjm-7q23

    Affected
    • Maven org.springframework.security:spring-security-saml2-service-provider >= 7.0.0, <= 7.0.5
    Fixed in
    7.0.6· Vendor fix available
    Issue
    An attacker with write permissions to the database table managed by JdbcAssertingPartyMetadataRepository (saml2assertingpartymetadata) may be able to store malicious serialized payloads in the columns containing the collection of verification or encryption credentials (verificationcredentials and encryptioncredentials, respectively). Affected versions: Spring Security 7.0.0 through 7.0.5.

    Recommended action: Upgrade to 7.0.6 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  4. Low, CVSS 3.7MavenPublished

    Spring Security SAML2 Service Provider: Decryption Oracle Vulnerability from Unsigned SAML Response and Logout Payloads

    CVE-2026-41694 · GHSA-ww38-37g9-m3q3

    Affected
    • Maven org.springframework.security:spring-security-saml2-service-provider >= 7.0.0, <= 7.0.5; >= 6.5.0, <= 6.5.10; >= 6.4.0, <= 6.4.16; >= 6.3.0, <= 6.3.16; >= 5.8.0, <= 5.8.25; <= 5.7.23
    Fixed in
    6.5.117.0.6· Partial vendor fix
    Issue
    Since Spring Security SAML decrypts SAML Responses as well as elements of SAML LogoutRequests and LogoutResponses without requiring a valid signature, attackers may be able to craft these SAML payloads and use the Service Provider as a decryption oracle. Affected versions: Spring Security 5.7.0 through 5.7.23; 5.8.0 through 5.8.25; 6.3.0 through 6.3.16; 6.4.0 through 6.4.16; 6.5.0 through 6.5.10; 7.0.0 through 7.0.5.

    Recommended action: Upgrade to 7.0.6 or 6.5.11 by release line; some affected versions have no fix yet, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →