Skip to content

← Actionable
High, CVSS 7.5

Spring Security SAML2 Service Provider: Unbounded writer inflates the compressed SAML payload into memory (DoS)

CVE-2026-40988GHSA-m69x-pw9p-7j3q

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-m69x-pw9p-7j3q lists affected ranges: Maven org.springframework.security:spring-security-saml2-service-provider >=7.0.0 =6.5.0 =6.4.0 =6.3.0 =5.8.0 =0 <=5.7.23

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-40988: 0.33% estimated exploitation activity in the next 30 days; percentile 26.35 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

An application using spring-security-saml2-service-provider and the REDIRECT binding for SAML 2.0 Login or Logout may be vulnerable to a denial of service by way of an unbounded writer that inflates the compressed SAML payload into memory. Affected versions: Spring Security 5.7.0 through 5.7.23; 5.8.0 through 5.8.25; 6.3.0 through 6.3.16; 6.4.0 through 6.4.16; 6.5.0 through 6.5.10; 7.0.0 through 7.0.5.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-m69x-pw9p-7j3q

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-40988

Advisory: Spring Security SAML2 Service Provider: Unbounded writer inflates the compressed SAML payload into memory (DoS)
IDs: CVE-2026-40988, GHSA-m69x-pw9p-7j3q
Record: https://patchnext.com/advisories/cve-2026-40988 (revision 1, source checked 26 Oct 2026, 16:54 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: org.springframework.security:spring-security-saml2-service-provider 7.0.6, 6.5.11. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.springframework.security:spring-security-saml2-service-provider: affected >= 7.0.0, <= 7.0.5; >= 6.5.0, <= 6.5.10; >= 6.4.0, <= 6.4.16; >= 6.3.0, <= 6.3.16; >= 5.8.0, <= 5.8.25; <= 5.7.23; fixed in 6.5.11, 7.0.6

## Suggested inspection (read-only)
- Maven org.springframework.security:spring-security-saml2-service-provider: check the installed version with your package manager.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.springframework.security:spring-security-saml2-service-provider.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-m69x-pw9p-7j3q (GitHub-reviewed advisory GHSA-m69x-pw9p-7j3q lists affected ranges: Maven org.springframework.security:spring-security-saml2-service-provider >=7.0.0 =6.5.0 =6.4.0 =6.3.0 =5.8.0 =0 <=5.7.23)

Commands are suggestions: review each one before running it.

Loading voting…