Skip to content

← Public intelligence

Maven package

org.springframework.graphql:spring-graphql

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

4 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 8.1MavenPublished

    Spring for GraphQL: Cross-Site WebSocket Hijacking

    CVE-2026-41700 · GHSA-m39w-hqxx-3r48

    Affected
    • Maven org.springframework.graphql:spring-graphql >= 2.0.0, <= 2.0.3; >= 1.4.0, <= 1.4.5; >= 1.3.0, <= 1.3.8; >= 1.0.0, <= 1.0.6
    Fixed in
    1.4.62.0.4· Partial vendor fix
    Issue
    Spring for GraphQL applications that have enabled the WebSocket transport are vulnerable to Cross-Site WebSocket Hijacking. An attacker can trick an authenticated user into visiting a malicious page, allowing the attacker to execute arbitrary GraphQL operations with the victim's credentials. Affected versions: Spring for GraphQL 2.0.0 through 2.0.3; 1.4.0 through 1.4.5; 1.3.0 through 1.3.8; 1.0.0 through 1.0.6.

    Recommended action: Upgrade to 2.0.4 or 1.4.6 by release line; some affected versions have no fix yet, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. High, CVSS 7.5MavenPublished

    Spring for GraphQL: Annotation Detection Vulnerability

    CVE-2026-41856 · GHSA-phxq-526m-79px

    Affected
    • Maven org.springframework.graphql:spring-graphql >= 2.0.0, <= 2.0.3; >= 1.4.0, <= 1.4.5; >= 1.3.0, <= 1.3.8; >= 1.0.0, <= 1.0.6
    Fixed in
    1.4.62.0.4· Partial vendor fix
    Issue
    The Spring GraphQL annotation detection mechanism for @Controller data fetchers may not correctly resolve annotations on methods within type hierarchies. This can be an issue if such annotations are used for authorization decisions. When all conditions are met, security annotations can be ignored at runtime. Affected versions: Spring for GraphQL 2.0.0 through 2.0.3; 1.4.0 through 1.4.5; 1.3.0 through 1.3.8; 1.0.0 through 1.0.6.

    Recommended action: Upgrade to 2.0.4 or 1.4.6 by release line; some affected versions have no fix yet, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. High, CVSS 8.1MavenPublished

    Spring for GraphQL: Unsafe Deserialization

    CVE-2026-41699 · GHSA-px92-q6rc-6mwv

    Affected
    • Maven org.springframework.graphql:spring-graphql >= 2.0.0, <= 2.0.3; >= 1.4.0, <= 1.4.5; >= 1.3.0, <= 1.3.8
    Fixed in
    1.4.62.0.4· Partial vendor fix
    Issue
    Spring for GraphQL applications are vulnerable to Unsafe Deserialization when processing paginated GraphQL queries. An attacker can craft a malicious GraphQL request that can lead to Remote Code Execution when the application exposes a paginated (Connection) field and the classpath contains specific classes that can be leveraged during deserialization. Affected versions: Spring for GraphQL 2.0.0 through 2.0.3; 1.4.0 through 1.4.5; 1.3.0 through 1.3.8.

    Recommended action: Upgrade to 2.0.4 or 1.4.6 by release line; some affected versions have no fix yet, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  4. Low, CVSS 3.1MavenPublished

    Spring for GraphQL may be exposed to GraphQL context with values from a different session

    CVE-2023-34047 · GHSA-frqc-f2h8-fjvf

    Affected
    • Maven org.springframework.graphql:spring-graphql >= 1.1.0, < 1.1.6; >= 1.2.0, < 1.2.3
    Fixed in
    1.2.31.1.6· Vendor fix available
    Issue
    A batch loader function in Spring for GraphQL versions 1.1.0 - 1.1.5 and 1.2.0 - 1.2.2 may be exposed to GraphQL context with values, including security context values, from a different session. An application is vulnerable if it provides a DataLoaderOptions instance when registering batch loader functions through DefaultBatchLoaderRegistry.

    Recommended action: Upgrade to 1.2.3 or 1.1.6 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →