Skip to content

← Actionable
High, CVSS 8.1

Spring for GraphQL: Unsafe Deserialization

CVE-2026-41699GHSA-px92-q6rc-6mwv

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.1 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-41699: 0.43% estimated exploitation activity in the next 30 days; percentile 37.38 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Spring for GraphQL applications are vulnerable to Unsafe Deserialization when processing paginated GraphQL queries. An attacker can craft a malicious GraphQL request that can lead to Remote Code Execution when the application exposes a paginated (Connection) field and the classpath contains specific classes that can be leveraged during deserialization. Affected versions: Spring for GraphQL 2.0.0 through 2.0.3; 1.4.0 through 1.4.5; 1.3.0 through 1.3.8.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-px92-q6rc-6mwv

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-41699

Advisory: Spring for GraphQL: Unsafe Deserialization
IDs: CVE-2026-41699, GHSA-px92-q6rc-6mwv
Record: https://patchnext.com/advisories/cve-2026-41699 (revision 1, source checked 26 Oct 2026, 16:55 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: org.springframework.graphql:spring-graphql 2.0.4, 1.4.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.springframework.graphql:spring-graphql: affected >= 2.0.0, <= 2.0.3; >= 1.4.0, <= 1.4.5; >= 1.3.0, <= 1.3.8; fixed in 1.4.6, 2.0.4

## Suggested inspection (read-only)
- Maven org.springframework.graphql:spring-graphql: check the installed version with your package manager.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.springframework.graphql:spring-graphql.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-px92-q6rc-6mwv (GitHub-reviewed advisory GHSA-px92-q6rc-6mwv lists affected ranges: Maven org.springframework.graphql:spring-graphql >=2.0.0 =1.4.0 =1.3.0 <=1.3.8)

Commands are suggestions: review each one before running it.

Loading voting…