Skip to content

← Public intelligence

Maven package

org.springframework.cloud:spring-cloud-gateway

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

3 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.5MavenPublished

    Spring Cloud Gateway's SSL bundle configuration silently bypassed

    CVE-2026-22750 · GHSA-hwqh-2684-54fc

    Affected
    • Maven org.springframework.cloud:spring-cloud-gateway >= 4.2.0, <= 4.2.0
    Fixed in
    4.2.1· Vendor fix available
    Issue
    When configuring SSL bundles in Spring Cloud Gateway by using the configuration property spring.ssl.bundle, the configuration was silently ignored and the default SSL configuration was used instead. Note: The 4.2.x branch is no longer under open source support. If you are using Spring Cloud Gateway 4.2.0 and are not an enterprise customer, you can upgrade to any Spring Cloud Gateway 4.2.x release newer than 4.2.0 available on Maven Centeral https://repo1.maven.org/maven2/org/springframework/cloud/spring-cloud-gateway/ . Ideally, if you are not an enterprise customer, you should be upgrading to 5.0.2 or 5.1.1, which are the current supported open source releases.

    Recommended action: Upgrade to 4.2.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Critical, CVSS 10.0Exploited · CISA KEVMavenPublished

    Spring Cloud Gateway vulnerable to Code Injection when Gateway Actuator endpoint enabled, exposed, unsecured

    CVE-2022-22947 · GHSA-3gx9-37ww-9qw6

    Affected
    • Maven org.springframework.cloud:spring-cloud-gateway < 3.0.7; >= 3.1.0, < 3.1.1
    Fixed in
    3.1.13.0.7· Vendor fix available
    Issue
    In Spring Cloud Gateway versions prior to 3.1.1+ and 3.0.7+ , applications are vulnerable to a code injection attack when the Gateway Actuator endpoint is enabled, exposed, and unsecured. A remote attacker could make a maliciously crafted request resulting in arbitrary remote execution on the remote host.

    Recommended action: Upgrade to 3.1.1 or 3.0.7 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.com (1)cisa.gov (2)Source checked Evidence →
  3. Medium, CVSS 6.5MavenPublished

    Request injection in Spring Cloud Gateway

    CVE-2021-22051 · GHSA-2r2v-q399-qq93

    Affected
    • Maven org.springframework.cloud:spring-cloud-gateway >= 3.0.0, < 3.0.5; >= 2.2.0, <= 2.2.10.RELEASE
    Fixed in
    3.0.52.2.10.RELEASE0.5· Vendor fix available
    Issue
    Applications using Spring Cloud Gateway are vulnerable to specifically crafted requests that could make an extra request on downstream services. Users of affected versions should apply the following mitigation: 3.0.x users should upgrade to 3.0.5+, 2.2.x users should upgrade to 2.2.10.RELEASE or newer.

    Recommended action: Upgrade to 3.0.5 or 2.2.10.RELEASE0.5 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →