Skip to content

← Actionable
Critical, CVSS 10.0Exploited · CISA KEV

Spring Cloud Gateway vulnerable to Code Injection when Gateway Actuator endpoint enabled, exposed, unsecured

CVE-2022-22947GHSA-3gx9-37ww-9qw6

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.springframework.cloud:spring-cloud-gateway 3.1.1, 3.0.7), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
Confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
CVSS
10.0 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
EPSS
  • CVE-2022-22947: 98.25% estimated exploitation activity in the next 30 days; percentile 99.92 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

In Spring Cloud Gateway versions prior to 3.1.1+ and 3.0.7+ , applications are vulnerable to a code injection attack when the Gateway Actuator endpoint is enabled, exposed, and unsecured. A remote attacker could make a maliciously crafted request resulting in arbitrary remote execution on the remote host.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-3gx9-37ww-9qw6

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-22947

Advisory: Spring Cloud Gateway vulnerable to Code Injection when Gateway Actuator endpoint enabled, exposed, unsecured
IDs: CVE-2022-22947, GHSA-3gx9-37ww-9qw6
Record: https://patchnext.com/advisories/cve-2022-22947 (revision 1, source checked 26 Oct 2026, 16:11 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 10.0)
Exploitation: confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
Vendor response: Vendor fix available; fixed versions by package: org.springframework.cloud:spring-cloud-gateway 3.1.1, 3.0.7. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.springframework.cloud:spring-cloud-gateway: affected < 3.0.7; >= 3.1.0, < 3.1.1; fixed in 3.1.1, 3.0.7

## Suggested inspection (read-only)
- Maven org.springframework.cloud:spring-cloud-gateway: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.springframework.cloud:spring-cloud-gateway.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-3gx9-37ww-9qw6 (GitHub-reviewed advisory GHSA-3gx9-37ww-9qw6 lists affected ranges: Maven org.springframework.cloud:spring-cloud-gateway >=0 =3.1.0 <3.1.1)
- Verified: https://www.cisa.gov/known-exploited-vulnerabilities-catalog (CISA added CVE-2022-22947 to the Known Exploited Vulnerabilities catalog on 2022-05-16.)

Commands are suggestions: review each one before running it.

Loading voting…