Skip to content

← Public intelligence

Maven package

org.springframework.boot:spring-boot-actuator-autoconfigure

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Critical, CVSS 9.8MavenPublished

    Spring Boot Security Bypass with Wildcard Pattern Matching on Cloud Foundry

    CVE-2023-20873 · GHSA-g5h3-w546-pj7f

    Affected
    • Maven org.springframework.boot:spring-boot-actuator-autoconfigure >= 3.0.0, < 3.0.6; >= 2.7.0, < 2.7.11; >= 2.6.0, < 2.6.15; < 2.5.15
    Fixed in
    3.0.62.7.112.5.152.6.15· Vendor fix available
    Issue
    In Spring Boot versions 3.0.0 - 3.0.5, 2.7.0 - 2.7.10, and older unsupported versions, an application that is deployed to Cloud Foundry could be susceptible to a security bypass. Users of affected versions should apply the following mitigation: 3.0.x users should upgrade to 3.0.6+. 2.7.x users should upgrade to 2.7.11+. Users of older, unsupported versions should upgrade to 3.0.6+ or 2.7.11+.

    Recommended action: Upgrade to 3.0.6, 2.7.11, 2.6.15 or 2.5.15 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →