Skip to content

← Actionable
Critical, CVSS 9.8

Spring Boot Security Bypass with Wildcard Pattern Matching on Cloud Foundry

CVE-2023-20873GHSA-g5h3-w546-pj7f

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.springframework.boot:spring-boot-actuator-autoconfigure 3.0.6, 2.7.11, 2.6.15, 2.5.15), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-g5h3-w546-pj7f lists affected ranges: Maven org.springframework.boot:spring-boot-actuator-autoconfigure >=3.0.0 =2.7.0 =2.6.0 =0 <2.5.15

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2023-20873: 1.12% estimated exploitation activity in the next 30 days; percentile 66.25 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

In Spring Boot versions 3.0.0 - 3.0.5, 2.7.0 - 2.7.10, and older unsupported versions, an application that is deployed to Cloud Foundry could be susceptible to a security bypass. Users of affected versions should apply the following mitigation: 3.0.x users should upgrade to 3.0.6+. 2.7.x users should upgrade to 2.7.11+. Users of older, unsupported versions should upgrade to 3.0.6+ or 2.7.11+.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-g5h3-w546-pj7f

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-20873

Advisory: Spring Boot Security Bypass with Wildcard Pattern Matching on Cloud Foundry
IDs: CVE-2023-20873, GHSA-g5h3-w546-pj7f
Record: https://patchnext.com/advisories/cve-2023-20873 (revision 1, source checked 26 Oct 2026, 16:30 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.springframework.boot:spring-boot-actuator-autoconfigure 3.0.6, 2.7.11, 2.6.15, 2.5.15. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.springframework.boot:spring-boot-actuator-autoconfigure: affected >= 3.0.0, < 3.0.6; >= 2.7.0, < 2.7.11; >= 2.6.0, < 2.6.15; < 2.5.15; fixed in 3.0.6, 2.7.11, 2.5.15, 2.6.15

## Suggested inspection (read-only)
- Maven org.springframework.boot:spring-boot-actuator-autoconfigure: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.springframework.boot:spring-boot-actuator-autoconfigure.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-g5h3-w546-pj7f (GitHub-reviewed advisory GHSA-g5h3-w546-pj7f lists affected ranges: Maven org.springframework.boot:spring-boot-actuator-autoconfigure >=3.0.0 =2.7.0 =2.6.0 =0 <2.5.15)

Commands are suggestions: review each one before running it.

Loading voting…