Medium, CVSS 5.3MavenPublished
Spring Boot Actuator denial of service vulnerability
CVE-2023-34055 · GHSA-jjfh-589g-3hjx
- Affected
- Maven org.springframework.boot:spring-boot-actuator < 2.7.18; >= 3.0.0, < 3.0.13; >= 3.1.0, < 3.1.6
- Fixed in
- 3.1.62.7.183.0.13· Vendor fix available
- Issue
- In Spring Boot versions 2.7.0 - 2.7.17, 3.0.0-3.0.12 and 3.1.0-3.1.5, it is possible for a user to provide specially crafted HTTP requests that may cause a denial-of-service (DoS) condition. Specifically, an application is vulnerable when all of the following are true: the application uses Spring MVC or Spring WebFlux org.springframework.boot:spring-boot-actuator is on the classpath
Recommended action: Upgrade to 3.1.6, 3.0.13 or 2.7.18 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.