Spring Boot Actuator denial of service vulnerability
CVE-2023-34055GHSA-jjfh-589g-3hjx
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.springframework.boot:spring-boot-actuator 3.1.6, 3.0.13, 2.7.18), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.springframework.boot:spring-boot-actuator
- Affected
- < 2.7.18>= 3.0.0, < 3.0.13>= 3.1.0, < 3.1.6
- Fixed in
- 3.1.6, 2.7.18, 3.0.13
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jjfh-589g-3hjx lists affected ranges: Maven org.springframework.boot:spring-boot-actuator >=0 =3.0.0 =3.1.0 <3.1.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
- EPSS
- CVE-2023-34055: 1.22% estimated exploitation activity in the next 30 days; percentile 68.68 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
In Spring Boot versions 2.7.0 - 2.7.17, 3.0.0-3.0.12 and 3.1.0-3.1.5, it is possible for a user to provide specially crafted HTTP requests that may cause a denial-of-service (DoS) condition. Specifically, an application is vulnerable when all of the following are true: the application uses Spring MVC or Spring WebFlux org.springframework.boot:spring-boot-actuator is on the classpath
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-jjfh-589g-3hjx
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-34055 Advisory: Spring Boot Actuator denial of service vulnerability IDs: CVE-2023-34055, GHSA-jjfh-589g-3hjx Record: https://patchnext.com/advisories/cve-2023-34055 (revision 1, source checked 26 Oct 2026, 16:30 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.springframework.boot:spring-boot-actuator 3.1.6, 3.0.13, 2.7.18. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.springframework.boot:spring-boot-actuator: affected < 2.7.18; >= 3.0.0, < 3.0.13; >= 3.1.0, < 3.1.6; fixed in 3.1.6, 2.7.18, 3.0.13 ## Suggested inspection (read-only) - Maven org.springframework.boot:spring-boot-actuator: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.springframework.boot:spring-boot-actuator. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-jjfh-589g-3hjx (GitHub-reviewed advisory GHSA-jjfh-589g-3hjx lists affected ranges: Maven org.springframework.boot:spring-boot-actuator >=0 =3.0.0 =3.1.0 <3.1.6) Commands are suggestions: review each one before running it.
Loading voting…