High, CVSS 8.6MavenPublished
Spring AI's MilvusVectorStore#doDelete(List) implementation is vulnerable to filter-expression injection via unsanitized document IDs
CVE-2026-41705 · GHSA-v632-2m87-7469
- Affected
- Maven org.springframework.ai:spring-ai-typesense-store >= 1.0.0, < 1.0.7; >= 1.1.0, < 1.1.6
- Fixed in
- 1.1.61.0.7· Vendor fix available
- Issue
- Spring AI's MilvusVectorStore#doDelete(List) implementation is vulnerable to filter-expression injection via unsanitized document IDs. Spring AI 1.0.x: affected from 1.0.0 through latest 1.0.x; upgrade to 1.0.7 or greater. Spring AI 1.1.x: affected from 1.1.0 through latest 1.1.x; upgrade to 1.1.6 or greater.
Recommended action: Upgrade to 1.1.6 or 1.0.7 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.