Skip to content

← Actionable
High, CVSS 8.6

Spring AI's MilvusVectorStore#doDelete(List) implementation is vulnerable to filter-expression injection via unsanitized document IDs

CVE-2026-41705GHSA-v632-2m87-7469

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.springframework.ai:spring-ai-milvus-store 1.1.6, 1.0.7; org.springframework.ai:spring-ai-typesense-store 1.1.6, 1.0.7), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-v632-2m87-7469 lists affected ranges: Maven org.springframework.ai:spring-ai-milvus-store >=1.0.0 =1.1.0 =1.0.0 =1.1.0 <1.1.6

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.6 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:L
EPSS
  • CVE-2026-41705: 0.35% estimated exploitation activity in the next 30 days; percentile 28.97 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Spring AI's MilvusVectorStore#doDelete(List) implementation is vulnerable to filter-expression injection via unsanitized document IDs. Spring AI 1.0.x: affected from 1.0.0 through latest 1.0.x; upgrade to 1.0.7 or greater. Spring AI 1.1.x: affected from 1.1.0 through latest 1.1.x; upgrade to 1.1.6 or greater.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-v632-2m87-7469

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-41705

Advisory: Spring AI's MilvusVectorStore#doDelete(List) implementation is vulnerable to filter-expression injection via unsanitized document IDs
IDs: CVE-2026-41705, GHSA-v632-2m87-7469
Record: https://patchnext.com/advisories/cve-2026-41705 (revision 1, source checked 26 Oct 2026, 16:45 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.springframework.ai:spring-ai-milvus-store 1.1.6, 1.0.7; org.springframework.ai:spring-ai-typesense-store 1.1.6, 1.0.7. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.springframework.ai:spring-ai-milvus-store: affected >= 1.0.0, < 1.0.7; >= 1.1.0, < 1.1.6; fixed in 1.1.6, 1.0.7
- Maven org.springframework.ai:spring-ai-typesense-store: affected >= 1.0.0, < 1.0.7; >= 1.1.0, < 1.1.6; fixed in 1.1.6, 1.0.7

## Suggested inspection (read-only)
- Maven org.springframework.ai:spring-ai-milvus-store: check the installed version with your package manager.
- Maven org.springframework.ai:spring-ai-typesense-store: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.springframework.ai:spring-ai-milvus-store, org.springframework.ai:spring-ai-typesense-store.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-v632-2m87-7469 (GitHub-reviewed advisory GHSA-v632-2m87-7469 lists affected ranges: Maven org.springframework.ai:spring-ai-milvus-store >=1.0.0 =1.1.0 =1.0.0 =1.1.0 <1.1.6)

Commands are suggestions: review each one before running it.

Loading voting…