Skip to content

← Public intelligence

Maven package

org.springframework:spring-expression

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

7 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.5MavenPublished

    Spring Framework Algorithmic Denial of Service via SpEL Expressions

    CVE-2026-41850 · GHSA-r5w3-xv2f-j59q

    Affected
    • Maven org.springframework:spring-expression >= 7.0.0, <= 7.0.7; >= 6.2.0, <= 6.2.18; >= 6.1.0, <= 6.1.21; <= 5.3.39
    Fixed in
    7.0.86.2.19· Partial vendor fix
    Issue
    Applications that evaluate user-supplied Spring Expression Language (SpEL) expressions are vulnerable to an Algorithmic Denial of Service (DoS). By providing a specially crafted expression, an attacker can trigger excessive resource consumption during evaluation, leading to application degradation or unavailability. Affected versions: Spring Framework 7.0.0 through 7.0.7; 6.2.0 through 6.2.18; 6.1.0 through 6.1.27; 5.3.0 through 5.3.48.

    Recommended action: Upgrade to 7.0.8 or 6.2.19 by release line; some affected versions have no fix yet, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Medium, CVSS 5.3MavenPublished

    Spring Framework Denial of Service via Unbounded Cache in SpEL

    CVE-2026-41851 · GHSA-wxpp-56q6-5pcg

    Affected
    • Maven org.springframework:spring-expression >= 7.0.0, <= 7.0.7; >= 6.2.0, <= 6.2.18; >= 6.1.0, <= 6.1.21; <= 5.3.39
    Fixed in
    7.0.86.2.19· Partial vendor fix
    Issue
    Applications which accept user-supplied Spring Expression Language (SpEL) expressions may be vulnerable to a Denial of Service (DoS) attack if the evaluation of a SpEL expression triggers unbounded cache growth. Affected versions: Spring Framework 7.0.0 through 7.0.7; 6.2.0 through 6.2.18; 6.1.0 through 6.1.27; 5.3.0 through 5.3.48.

    Recommended action: Upgrade to 7.0.8 or 6.2.19 by release line; some affected versions have no fix yet, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. Low, CVSS 3.7MavenPublished

    Spring Framework Arbitrary Method Invocation in SpEL Expressions

    CVE-2026-41852 · GHSA-9f52-rjqv-25qv

    Affected
    • Maven org.springframework:spring-expression >= 7.0.0, <= 7.0.7; >= 6.2.0, <= 6.2.18; >= 6.1.0, <= 6.1.21; <= 5.3.39
    Fixed in
    7.0.86.2.19· Partial vendor fix
    Issue
    A vulnerability in Spring Expression Language (SpEL) evaluation logic allows for arbitrary zero-argument method invocation, even within restricted or read-only contexts, which may allow an attacker to invoke unintended application logic. Affected versions: Spring Framework 7.0.0 through 7.0.7; 6.2.0 through 6.2.18; 6.1.0 through 6.1.27; 5.3.0 through 5.3.48.

    Recommended action: Upgrade to 7.0.8 or 6.2.19 by release line; some affected versions have no fix yet, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  4. Medium, CVSS 5.1MavenPublished

    Spring Framework vulnerable to Denial of Service

    CVE-2024-38808 · GHSA-9cmq-m9j5-mvww

    Affected
    • Maven org.springframework:spring-expression < 5.3.39
    Fixed in
    5.3.39· Vendor fix available
    Issue
    In Spring Framework versions 5.3.0 - 5.3.38 and older unsupported versions, it is possible for a user to provide a specially crafted Spring Expression Language (SpEL) expression that may cause a denial of service (DoS) condition. Older, unsupported versions are also affected. Specifically, an application is vulnerable when the following is true: The application evaluates user-supplied SpEL expressions.

    Recommended action: Upgrade to 5.3.39 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  5. High, CVSS 7.5MavenPublished

    Spring Framework vulnerable to denial of service

    CVE-2023-20863 · GHSA-wxqc-pxw9-g2p8

    Affected
    • Maven org.springframework:spring-expression >= 6.0.0, < 6.0.8; >= 5.3.0, < 5.3.27; < 5.2.24.RELEASE
    Fixed in
    6.0.85.2.24.RELEASE5.3.27· Vendor fix available
    Issue
    In Spring Framework versions prior to 5.2.24.release+ , 5.3.27+ and 6.0.8+ , it is possible for a user to provide a specially crafted Spring Expression Language (SpEL) expression that may cause a denial-of-service (DoS) condition.

    Recommended action: Upgrade to 6.0.8, 5.3.27 or 5.2.24.RELEASE by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  6. Medium, CVSS 6.5MavenPublished

    Spring Framework vulnerable to denial of service via specially crafted SpEL expression

    CVE-2023-20861 · GHSA-564r-hj7v-mcr5

    Affected
    • Maven org.springframework:spring-expression >= 6.0.0, < 6.0.7; >= 5.3.0, < 5.3.26; < 5.2.23.RELEASE
    Fixed in
    5.2.23.RELEASE6.0.75.3.26· Vendor fix available
    Issue
    In Spring Framework versions 6.0.0 - 6.0.6, 5.3.0 - 5.3.25, 5.2.0.RELEASE - 5.2.22.RELEASE, and older unsupported versions, it is possible for a user to provide a specially crafted SpEL expression that may cause a denial-of-service (DoS) condition.

    Recommended action: Upgrade to 6.0.7, 5.3.26 or 5.2.23.RELEASE by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  7. Medium, CVSS 6.5MavenPublished

    Allocation of Resources Without Limits or Throttling in Spring Framework

    CVE-2022-22950 · GHSA-558x-2xjg-6232

    Affected
    • Maven org.springframework:spring-expression >= 5.3.0, < 5.3.17; < 5.2.20.RELEASE
    Fixed in
    5.2.20.RELEASE5.3.17· Vendor fix available
    Issue
    In Spring Framework versions 5.3.0 - 5.3.16, 5.2.0.RELEASE - 5.2.19.RELEASE, and older unsupported versions, it is possible for a user to provide a specially crafted SpEL expression that may cause a denial of service condition.

    Recommended action: Upgrade to 5.3.17 or 5.2.20.RELEASE by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →