Skip to content

← Actionable
High, CVSS 7.5

Spring Framework Algorithmic Denial of Service via SpEL Expressions

CVE-2026-41850GHSA-r5w3-xv2f-j59q

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-41850: 0.39% estimated exploitation activity in the next 30 days; percentile 32.83 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Applications that evaluate user-supplied Spring Expression Language (SpEL) expressions are vulnerable to an Algorithmic Denial of Service (DoS). By providing a specially crafted expression, an attacker can trigger excessive resource consumption during evaluation, leading to application degradation or unavailability. Affected versions: Spring Framework 7.0.0 through 7.0.7; 6.2.0 through 6.2.18; 6.1.0 through 6.1.27; 5.3.0 through 5.3.48.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-r5w3-xv2f-j59q

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-41850

Advisory: Spring Framework Algorithmic Denial of Service via SpEL Expressions
IDs: CVE-2026-41850, GHSA-r5w3-xv2f-j59q
Record: https://patchnext.com/advisories/cve-2026-41850 (revision 1, source checked 26 Oct 2026, 16:54 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: org.springframework:spring-expression 7.0.8, 6.2.19. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.springframework:spring-expression: affected >= 7.0.0, <= 7.0.7; >= 6.2.0, <= 6.2.18; >= 6.1.0, <= 6.1.21; <= 5.3.39; fixed in 7.0.8, 6.2.19

## Suggested inspection (read-only)
- Maven org.springframework:spring-expression: check the installed version with your package manager.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.springframework:spring-expression.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-r5w3-xv2f-j59q (GitHub-reviewed advisory GHSA-r5w3-xv2f-j59q lists affected ranges: Maven org.springframework:spring-expression >=7.0.0 =6.2.0 =6.1.0 =0 <=5.3.39)

Commands are suggestions: review each one before running it.

Loading voting…