Skip to content

← Public intelligence

Maven package

org.springframework:spring

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

3 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Critical, CVSS 9.1MavenPublished

    Spring Framework is vulnerable to security bypass via mvcRequestMatcher pattern mismatch

    CVE-2023-20860 · GHSA-7phw-cxx7-q9vq

    Affected
    • Maven org.springframework:spring >= 6.0.0, < 6.0.7; >= 5.3.0, < 5.3.26
    Fixed in
    6.0.75.3.26· Vendor fix available
    Issue
    Spring Framework running version 6.0.0 - 6.0.6 or 5.3.0 - 5.3.25 using "" as a pattern in Spring Security configuration with the mvcRequestMatcher creates a mismatch in pattern matching between Spring Security and Spring MVC, and the potential for a security bypass.

    Recommended action: Upgrade to 6.0.7 or 5.3.26 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Medium, CVSS 4.3MavenPublished

    Improper Output Neutralization for Logs in Spring Framework

    CVE-2021-22096 · GHSA-rfmp-97jj-h8m6

    Affected
    • Maven org.springframework:spring >= 5.2.0, <= 5.2.17; >= 5.3.0, <= 5.3.10
    Fixed in
    5.3.115.2.18· Vendor fix available
    Issue
    In Spring Framework versions 5.3.0 - 5.3.10, 5.2.0 - 5.2.17, and older unsupported versions, it is possible for a user to provide malicious input to cause the insertion of additional log entries.

    Recommended action: Upgrade to 5.3.11 or 5.2.18 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. UnratedMavenPublished

    Improper Control of Generation of Code ('Code Injection') in Spring Framework

    CVE-2010-1622 · GHSA-vpr3-f594-mg5g

    Affected
    • Maven org.springframework:spring >= 2.5.0, <= 2.5.6; >= 3.0.0, <= 3.0.2
    Fixed in
    3.0.32.5.7· Vendor fix available
    Issue
    SpringSource Spring Framework 2.5.x before 2.5.6.SEC02, 2.5.7 before 2.5.7.SR01, and 3.0.x before 3.0.3 allows remote attackers to execute arbitrary code via an HTTP request containing class.classLoader.URLs[0]=jar: followed by a URL of a crafted .jar file.

    Recommended action: Upgrade to 3.0.3 or 2.5.7 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →