Improper Control of Generation of Code ('Code Injection') in Spring Framework
CVE-2010-1622GHSA-vpr3-f594-mg5g
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.springframework:spring 3.0.3, 2.5.7), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.springframework:spring
- Affected
- >= 2.5.0, <= 2.5.6>= 3.0.0, <= 3.0.2
- Fixed in
- 3.0.3, 2.5.7
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-vpr3-f594-mg5g lists affected ranges: Maven org.springframework:spring >=2.5.0 =3.0.0 <=3.0.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2010-1622: 52.00% estimated exploitation activity in the next 30 days; percentile 98.96 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
SpringSource Spring Framework 2.5.x before 2.5.6.SEC02, 2.5.7 before 2.5.7.SR01, and 3.0.x before 3.0.3 allows remote attackers to execute arbitrary code via an HTTP request containing class.classLoader.URLs[0]=jar: followed by a URL of a crafted .jar file.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-vpr3-f594-mg5g
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2010-1622
Advisory: Improper Control of Generation of Code ('Code Injection') in Spring Framework
IDs: CVE-2010-1622, GHSA-vpr3-f594-mg5g
Record: https://patchnext.com/advisories/cve-2010-1622 (revision 1, source checked 26 Oct 2026, 16:29 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.springframework:spring 3.0.3, 2.5.7. A vendor fix does not mean a deployment is fixed.
## Affected components
- Maven org.springframework:spring: affected >= 2.5.0, <= 2.5.6; >= 3.0.0, <= 3.0.2; fixed in 3.0.3, 2.5.7
## Suggested inspection (read-only)
- Maven org.springframework:spring: check the installed version with your package manager.
## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.
## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.springframework:spring.
- Repeat the inspection and confirm that only fixed versions remain installed.
## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.
## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.
## Sources
- Verified: https://github.com/advisories/GHSA-vpr3-f594-mg5g (GitHub-reviewed advisory GHSA-vpr3-f594-mg5g lists affected ranges: Maven org.springframework:spring >=2.5.0 =3.0.0 <=3.0.2)
Commands are suggestions: review each one before running it.Loading voting…