Skip to content

← Public intelligence

Maven package

org.sonatype.nexus.ci:nexus-jenkins-plugin

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

4 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 4.2MavenPublished

    Jenkins Nexus Platform Plugin missing permission check

    CVE-2023-50769 · GHSA-4g5f-w3mh-w99m

    Affected
    • Maven org.sonatype.nexus.ci:nexus-jenkins-plugin < 3.18.1-01
    Fixed in
    3.18.1-01· Vendor fix available
    Issue
    Jenkins Nexus Platform Plugin 3.18.0-03 and earlier does not perform permission checks in methods implementing form validation. This allows attackers with Overall/Read permission to connect to an attacker-specified HTTP server using attacker-specified credentials IDs obtained through another method, capturing credentials stored in Jenkins. Additionally, these form validation methods do not require POST requests, resulting in a cross-site request forgery (CSRF) vulnerability. Nexus Platform Plugin 3.18.1-01 requires POST requests and Overall/Administer permission for the affected form validation methods.

    Recommended action: Upgrade to 3.18.1-01 (pre-release) or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Medium, CVSS 4.2MavenPublished

    Jenkins Nexus Platform Plugin Cross-Site Request Forgery vulnerability

    CVE-2023-50768 · GHSA-phjq-7xqp-2526

    Affected
    • Maven org.sonatype.nexus.ci:nexus-jenkins-plugin < 3.18.1-01
    Fixed in
    3.18.1-01· Vendor fix available
    Issue
    Jenkins Nexus Platform Plugin 3.18.0-03 and earlier does not perform permission checks in methods implementing form validation. This allows attackers with Overall/Read permission to connect to an attacker-specified HTTP server using attacker-specified credentials IDs obtained through another method, capturing credentials stored in Jenkins. Additionally, these form validation methods do not require POST requests, resulting in a cross-site request forgery (CSRF) vulnerability. Nexus Platform Plugin 3.18.1-01 requires POST requests and Overall/Administer permission for the affected form validation methods.

    Recommended action: Upgrade to 3.18.1-01 (pre-release) or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. High, CVSS 7.1MavenPublished

    Jenkins Nexus Platform Plugin Cross-Site Request Forgery vulnerability

    CVE-2023-50766 · GHSA-4gfc-72gw-v385

    Affected
    • Maven org.sonatype.nexus.ci:nexus-jenkins-plugin < 3.18.1-01
    Fixed in
    3.18.1-01· Vendor fix available
    Issue
    Jenkins Nexus Platform Plugin 3.18.0-03 and earlier does not perform permission checks in methods implementing form validation. This allows attackers with Overall/Read permission to send an HTTP request to an attacker-specified URL and parse the response as XML. Additionally, the plugin does not configure its XML parser to prevent XML external entity (XXE) attacks, so attackers can have Jenkins parse a crafted XML response that uses external entities for extraction of secrets from the Jenkins controller or server-side request forgery. Additionally, these form validation methods do not require POST requests, resulting in a cross-site request forgery (CSRF) vulnerability. Nexus Platform Plugin 3.18.1-01 configures its XML parser to prevent XML external entity (XXE) attacks. Additionally, POST requests and Overall/Administer permission are required for the affected HTTP endpoints.

    Recommended action: Upgrade to 3.18.1-01 (pre-release) or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  4. High, CVSS 7.1MavenPublished

    Jenkins Nexus Platform Plugin missing permission check

    CVE-2023-50767 · GHSA-9vrm-747r-668v

    Affected
    • Maven org.sonatype.nexus.ci:nexus-jenkins-plugin < 3.18.1-01
    Fixed in
    3.18.1-01· Vendor fix available
    Issue
    Jenkins Nexus Platform Plugin 3.18.0-03 and earlier does not perform permission checks in methods implementing form validation. This allows attackers with Overall/Read permission to send an HTTP request to an attacker-specified URL and parse the response as XML. Additionally, the plugin does not configure its XML parser to prevent XML external entity (XXE) attacks, so attackers can have Jenkins parse a crafted XML response that uses external entities for extraction of secrets from the Jenkins controller or server-side request forgery. Additionally, these form validation methods do not require POST requests, resulting in a cross-site request forgery (CSRF) vulnerability. Nexus Platform Plugin 3.18.1-01 configures its XML parser to prevent XML external entity (XXE) attacks. Additionally, POST requests and Overall/Administer permission are required for the affected HTTP endpoints.

    Recommended action: Upgrade to 3.18.1-01 (pre-release) or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →