Jenkins Nexus Platform Plugin Cross-Site Request Forgery vulnerability
CVE-2023-50766GHSA-4gfc-72gw-v385
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.sonatype.nexus.ci:nexus-jenkins-plugin 3.18.1-01), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.sonatype.nexus.ci:nexus-jenkins-plugin
- Affected
- < 3.18.1-01
- Fixed in
- 3.18.1-01
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4gfc-72gw-v385 lists affected ranges: Maven org.sonatype.nexus.ci:nexus-jenkins-plugin >=0 <3.18.1-01
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.1 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:N
- EPSS
- CVE-2023-50766: 0.45% estimated exploitation activity in the next 30 days; percentile 38.91 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Jenkins Nexus Platform Plugin 3.18.0-03 and earlier does not perform permission checks in methods implementing form validation. This allows attackers with Overall/Read permission to send an HTTP request to an attacker-specified URL and parse the response as XML. Additionally, the plugin does not configure its XML parser to prevent XML external entity (XXE) attacks, so attackers can have Jenkins parse a crafted XML response that uses external entities for extraction of secrets from the Jenkins controller or server-side request forgery. Additionally, these form validation methods do not require POST requests, resulting in a cross-site request forgery (CSRF) vulnerability. Nexus Platform Plugin 3.18.1-01 configures its XML parser to prevent XML external entity (XXE) attacks. Additionally, POST requests and Overall/Administer permission are required for the affected HTTP endpoints.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-4gfc-72gw-v385
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-50766 Advisory: Jenkins Nexus Platform Plugin Cross-Site Request Forgery vulnerability IDs: CVE-2023-50766, GHSA-4gfc-72gw-v385 Record: https://patchnext.com/advisories/cve-2023-50766 (revision 1, source checked 26 Oct 2026, 16:21 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.sonatype.nexus.ci:nexus-jenkins-plugin 3.18.1-01. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.sonatype.nexus.ci:nexus-jenkins-plugin: affected < 3.18.1-01; fixed in 3.18.1-01 ## Suggested inspection (read-only) - Maven org.sonatype.nexus.ci:nexus-jenkins-plugin: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.sonatype.nexus.ci:nexus-jenkins-plugin. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-4gfc-72gw-v385 (GitHub-reviewed advisory GHSA-4gfc-72gw-v385 lists affected ranges: Maven org.sonatype.nexus.ci:nexus-jenkins-plugin >=0 <3.18.1-01) Commands are suggestions: review each one before running it.
Loading voting…