Skip to content

← Public intelligence

Maven package

org.powernukkit:powernukkit

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Critical, CVSS 10.0MavenPublished

    Remote code injection, Improper Input Validation and Uncontrolled Recursion in Log4j library

    GHSA-3qpm-h9ch-px3c

    Affected
    • Maven org.powernukkit:powernukkit <= 1.5.2.0
    Fixed in
    1.5.2.1· Vendor fix available
    Issue
    The version used of Log4j, the library used for logging by PowerNukkit, is subject to a remote code execution vulnerability via the ldap JNDI parser. It's well detailed at CVE-2021-44228 and CVE-2021-45105(https://github.com/advisories/GHSA-p6xc-xr62-6r2g). Impact Malicious client code could be used to send messages and cause remote code execution on the server. Patches PowerNukkit 1.5.2.1 is a patch-release that only updates the Log4j version to 2.17.0 and should be used instead of 1.5.2.0. All versions prior to 1.5.2.1 are affected and are not patched. Workarounds If you can't upgrade, you can use the -Dlog4j2.formatMsgNoLookups=true startup argument as remediation, as this prevents the vulnerability from happening. References https://github.com/advisories/GHSA-jfh8-c2jp-5v3q https://github.com/advisories/GHSA-p6xc-xr62-6r2g For more information If you have any questions or comments about this advisory: Open an issue in the PowerNukkit repository

    Recommended action: Upgrade to 1.5.2.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →