Remote code injection, Improper Input Validation and Uncontrolled Recursion in Log4j library
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.powernukkit:powernukkit 1.5.2.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.powernukkit:powernukkit
- Affected
- <= 1.5.2.0
- Fixed in
- 1.5.2.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-3qpm-h9ch-px3c lists affected ranges: Maven org.powernukkit:powernukkit >=0 <=1.5.2.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 10.0 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Summary The version used of Log4j, the library used for logging by PowerNukkit, is subject to a remote code execution vulnerability via the ldap JNDI parser. It's well detailed at CVE-2021-44228 and CVE-2021-45105(https://github.com/advisories/GHSA-p6xc-xr62-6r2g). Impact Malicious client code could be used to send messages and cause remote code execution on the server. Patches PowerNukkit 1.5.2.1 is a patch-release that only updates the Log4j version to 2.17.0 and should be used instead of 1.5.2.0. All versions prior to 1.5.2.1 are affected and are not patched. Workarounds If you can't upgrade, you can use the -Dlog4j2.formatMsgNoLookups=true startup argument as remediation, as this prevents the vulnerability from happening. References https://github.com/advisories/GHSA-jfh8-c2jp-5v3q https://github.com/advisories/GHSA-p6xc-xr62-6r2g For more information If you have any questions or comments about this advisory: Open an issue in the PowerNukkit repository
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-3qpm-h9ch-px3c
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-3qpm-h9ch-px3c Advisory: Remote code injection, Improper Input Validation and Uncontrolled Recursion in Log4j library IDs: GHSA-3qpm-h9ch-px3c Record: https://patchnext.com/advisories/ghsa-3qpm-h9ch-px3c (revision 1, source checked 26 Oct 2026, 15:53 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 10.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.powernukkit:powernukkit 1.5.2.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.powernukkit:powernukkit: affected <= 1.5.2.0; fixed in 1.5.2.1 ## Suggested inspection (read-only) - Maven org.powernukkit:powernukkit: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.powernukkit:powernukkit. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-3qpm-h9ch-px3c (GitHub-reviewed advisory GHSA-3qpm-h9ch-px3c lists affected ranges: Maven org.powernukkit:powernukkit >=0 <=1.5.2.0) Commands are suggestions: review each one before running it.
Loading voting…